在线检测未来函数

大智慧MACD金叉背离指标公式

来源:Internet,编辑:股旁网,2011-11-13

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
STICKLINE(MACD>0,MACD, 0, 0, 1),color0055cc;
STICKLINE(MACD<0,MACD, 0, 0, 1),Colordddd00;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0.1,0),COLORYELLOW;
DRAWICON(BARSTATUS=2 AND MACD>REF(MACD,1),HHV(MACD,35), 7),VALIGN2;
DRAWICON(BARSTATUS=2 AND MACD<REF(MACD,1),HHV(MACD,35), 8),VALIGN1;
PARTLINE(DIF,DIF>ref(DIF,1),RGB(255,50,0),DIF<ref(DIF,1),RGB(255,255,255)),LINETHICK2;
PARTLINE(MACD,MACD>0,RGB(205,100,100),MACD<0,RGB(0,200,0)),COLORSTICK;
VAR1:=HHV(DEA,60);
VAR2:=LLV(DEA,100);
VAR3:=DEA-(DIF-DEA);
上轨:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
下轨:IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
主升:= DIF>0 AND DIF>DEA;
FILLRGN(DIF,DEA,DIF>DEA,RGB(130,0,0),DIF<DEA,RGB(0,50,0));
FILLRGN(DIF,DEA,主升,RGB(100,0,0));
低金:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低金,0,-0.10,6,0),COLORYELLOW;
DRAWTEXT(低金,-0.05,' 低金'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二金:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二金,0,-0.10,6,0),ColorFF00FF;
DRAWICON(二金,dea*1.04,13) ;
DRAWTEXT(二金,-0.08,' 二金'),ColorFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.13,6,0),Colorred;
DRAWTEXT(底背离,dea,' 底背离'),Colorred;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
{www.gUPaNg.com 股旁网_最新股票指标公式}
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(顶背离,dea,' 顶背离'),Colorgreen;
a1:=DIF<0 and DEA<0;
a2:=a1>REF(a1,1);
a3:=BARSLAST(a2);
a4:=COUNT(DEA>0 and DIF>0,a3)=0;
a5:=CROSS(DIF,DEA);{金叉}
a6:=BARSLAST(a5);
a7:=REF(a6,a6+1)+a6;
a8:=(DiF+DEA)/2;
a9:=(HIGH+LOW)/2;
a10:=a5 and a7<a3 and a4 and a8>REF(a8,a7) and a9<REF(a9,a7) and macd>0;
DRAWTEXT(a10,dif*0.95,'★'),COLORyellow;

大智慧MACD金叉背离指标公式

 

相关文章