在线检测未来函数

通达信股价预测+买点+资金净流入量主图指标公式

来源:Internet,编辑:股旁网,2012-01-11

N:=27;PP:=0.03;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
MA5:MA(C,5);MA10:MA(C,10);MA30:MA(C,30);
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWICON(选股,L*0.975,1);
{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
预测低一:=O-B2;
预测高一:=O+B2;
{预测当天股价公式}
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:=GGG;
{预测今日最高价公式}
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1);
DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORGREEN;
DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORGREEN;
DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORGREEN;
DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORGREEN;
DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORGREEN,LINETHICK1;
买回价:=预测低二*1.015;
卖出价:=买回价*(1+PP);
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLORMAGENTA;
DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLORMAGENTA;
DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.01,0.02,0,'★ ===========================================★'),COLORRED;
DRAWTEXT_FIX(1,0.12,0.05,0,'T+0 操 作'),COLORRED;
DRAWTEXT_FIX(1,0.01,0.08,0,'操 '),COLORRED;
DRAWTEXT_FIX(1,0.01,0.12,0,'盘 '),COLORRED;
DRAWTEXT_FIX(1,0.01,0.16,0,'铁'),COLORRED;
DRAWTEXT_FIX(1,0.01,0.20,0,'律'),COLORRED;
DRAWTEXT_FIX(1,0.32,0.08,0,'坚 '),COLORRED;
DRAWTEXT_FIX(1,0.32,0.12,0,'决 '),COLORRED;
DRAWTEXT_FIX(1,0.32,0.16,0,'执'),COLORRED;
DRAWTEXT_FIX(1,0.32,0.20,0,'行'),COLORRED;
DRAWTEXT_FIX(1,0.01,0.24,0,'★ ===========================================★'),COLORRED;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

通达信股价预测+买点+资金净流入量主图指标公式

 

相关文章