在线检测未来函数

通达信缠中说禅趋势主图指标公式

来源:Internet,编辑:股旁网,2012-02-13

SHORT:=7;LONG:=19;
T:=PERIOD;
D:=IF(T=0,30,{1F}
IF(T=1,25,{5F}
IF(T=8,25,{多分钟}
IF(T=2,20,{15F}
IF(T=3,20,{30F}
IF(T=4,20,{60F}
IF(T=5,10,{日}
IF(T=6,10,{周}
IF(T=7,10,{月}
IF(T=9,10,{多日}
IF(T=10,10{季},10{年})))))))))));
RMA:EMA(CLOSE,SHORT),COLORLIGRAY;
NMA:EMA(CLOSE,LONG),COLORMAGENTA;
RISK:IF(NMA>RMA,NMA,DRAWNULL),COLORGREEN;
UP:DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1) AND L=LLV(L,D) AND RMA<=NMA,L,H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1) AND H=HHV(H,D) AND RMA>=NMA,H,0),COLOR0000FF,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
DOWN:DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1) AND H=HHV(H,D) AND RMA>=NMA,H,L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1) AND L=LLV(L,D) AND RMA<=NMA,L,0),COLOR00FF00,LINETHICK2;
UH:HHV(H,55),COLORBROWN;
MID:(HHV(H,55)+LLV(L,55))/2,COLORBROWN;
DL:LLV(L,55),COLORBROWN;

通达信缠中说禅趋势主图指标公式

 

相关文章