在线检测未来函数

大智慧智能分析量能主图指标公式

来源:Internet,编辑:股旁网,2012-02-28

N:=5;N1:=10;N2:=20;N3:=30;
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
{DRAWGBKLAST(C>0,STRIP(RGB(90,90,90),RGB(0,0,0),0));
STICKLINE(C>=O,C,O,8,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,4,0),COLOR0000cc ;
STICKLINE(C>=O,C,O,2,0),COLOR0000ee;
STICKLINE(C>=O,H,L,0,0),COLOR0000ff;
STICKLINE(C<=O,C,O,8,0),Color7B7b00;
STICKLINE(C<=O,C,O,6,0),Color909000;
STICKLINE(C<=O,C,O,4,0),ColorA8a800;
STICKLINE(C<=O,C,O,2,0),COLORcece00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;}
NN:= DISPSTATUS=2;
Mb1:MA(c,n),ColorFFFfff,linethick1,DOTLINE;
Mb2:MA(c,n1),Color00Ffff,linethick1,DOTLINE;
Mb3:MA(c,n2),Color208fff,linethick1,DOTLINE;
Mb4:MA(c,n3),Colorff00ff,linethick0,DOTLINE;
VAR3:=(HIGH < REF(LOW,1));
VAR4:=(LOW > REF(HIGH,1));
DRAWTEXT(VAR3,(HIGH ),'↓QK'),ALIGN0,VALIGN2,COLORffFFff,linethick3;
DRAWTEXT(VAR4,(LOW ),'↑QK'),ALIGN0,VALIGN0,COLOR00ffff,linethick3;
DRAWTEXT(nn,Mb1,''+NUMTOSTRN(Mb1,2)+''),ALIGN0,ColorFFFFFF,LINETHICK1;
DRAWTEXT(nn,Mb2,''+NUMTOSTRN(Mb2,2)+''),ALIGN0,Color00FFFF,LINETHICK1;
DRAWTEXT(nn,Mb3,''+NUMTOSTRN(Mb3,2)+''),ALIGN0,Color208FFF,LINETHICK1;
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);
UU:=BACKSET(BARSTATUS,BARSLAST(LD)+1);
{www.gupang.com 股旁网_大智慧股票指标公式}
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
一低:REF(L,BARSLAST(VV)),COLOR99FF66,LINETHICK1,DOTLINE;
二低:REF(L,BARSLAST(XX)),COLORFF66FF,LINETHICK1,DOTLINE;
一高:REF(H,BARSLAST(VV2)),COLOR99FF66,LINETHICK1,DOTLINE;
二高:REF(H,BARSLAST(XX2)),COLORFF66FF,LINETHICK1,DOTLINE;
{----}
xz:=DYNAINFO(7);{取得最新动态行情: 最新}
sz:=xz-一低;
zz:=sz/一低*100;
gg:=一高-一低;
{V:=gg/一低*100};
{V:=GG/一高*100};
k:=一高-二低;
w:=k/二低*100;
kg:=二高-二低;
wg:=kg/二高*100;
DRAWTEXTABS(52,110,' 前一低到 当前幅度 :('+NUMTOSTRn(zz,2)+'%)'+'涨('+NUMTOSTRn(sz,2)+')'+''),colorffffff;
DRAWTEXTABS(52,125,' 前一高到 前一低 :(-'+NUMTOSTRn(V,2)+'%)'+'跌('+NUMTOSTRn(gg,2)+')'+''),color00ff00;
DRAWTEXTABS(52,140,' 前二低到 前一高 :('+NUMTOSTRn(w,2)+'%)'+'涨('+NUMTOSTRn(k,2)+')'+''),colorFEBAF5;
DRAWTEXTABS(52,155,' 前二高到 前二低 :(-'+NUMTOSTRn(wg,2)+'%)'+'跌('+NUMTOSTRn(kg,2)+')'+''),colorFEBAF5;
DRAWTEXT(nn,一低,'前一低: '+NUMTOSTRN(一低,2)+''),ALIGN2,Color00dd00,VALIGN2;
DRAWTEXT(nn,一高,'前一高: '+NUMTOSTRN(一高,2)+''),ALIGN2,Color00dd00,VALIGN2;
DRAWTEXT(nn,二低,'前二低: '+NUMTOSTRN(二低,2)+''),ALIGN2,Colordd00ff,LINETHICK1;
DRAWTEXT(nn,二高,'前二高: '+NUMTOSTRN(二高,2)+''),ALIGN2,Colordd00ff,LINETHICK1;
mc:=REF(c,1);
阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));
阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);
止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));
止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);
阻力位a:=IF((mc > 200),(mc * 1.01),(mc * 1.07));
阻力位2:=IF((mc < 10),(mc * 1.05),阻力位a);
止损位b:=IF((mc > 200),(mc * 0.99),(mc * 0.93));
止损位2:=IF((mc < 10),(mc * 0.95),止损位b);
DRAWTEXTABS(58,80,'[昨/今日 止损位 :'+NUMTOSTRn(止损位b,2)+'/'+NUMTOSTRn(止损位1,2)+'**]'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(58,95,'[昨/今日 阻力位 :'+NUMTOSTRn(阻力位2,2)+'/'+NUMTOSTRn(阻力位1,2)+']'),LINETHICK1,colorFEBAF5;
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
DRAWTEXTABS(75,8,' 《顺势操作》'),ColorFFFF00;
DRAWTEXTABS(150,8,' 重心:'+重心),Color208FFF;
DRAWTEXTABS(75,27,' 支 撑'),ColorFFFFFF;
DRAWTEXTABS(75,44,' '+支撑Ⅰ),ColorFFFFFF;
DRAWTEXTABS(75,62,' '+支撑Ⅱ),ColorFFFFFF;
DRAWTEXTABS(120,27,' 压 力'),Color00FF00;
DRAWTEXTABS(120,44,' '+压力Ⅰ),Color00FF00;
DRAWTEXTABS(120,62,' '+压力Ⅱ),Color00FF00;
DRAWTEXTABS(75,5,'│'),Color00FFFF;
DRAWTEXTABS(75,17,'│'),Color00FFFF;
DRAWTEXTABS(75,29,'│'),Color00FFFF;
DRAWTEXTABS(75,41,'│'),Color00FFFF;
DRAWTEXTABS(75,53,'│'),Color00FFFF;
DRAWTEXTABS(75,65,'│'),Color00FFFF;
DRAWTEXTABS(218,5,'│'),Color00FFFF;
DRAWTEXTABS(218,17,'│'),Color00FFFF;
DRAWTEXTABS(218,29,'│'),Color00FFFF;
DRAWTEXTABS(218,41,'│'),Color00FFFF;
DRAWTEXTABS(218,53,'│'),Color00FFFF;
DRAWTEXTABS(218,65,'│'),Color00FFFF;
DRAWTEXTABS(146,25,'│'),Color00FFFF;
DRAWTEXTABS(146,29,'│'),Color00FFFF;
DRAWTEXTABS(146,41,'│'),Color00FFFF;
DRAWTEXTABS(146,53,'│'),Color00FFFF;
DRAWTEXTABS(146,65,'│'),Color00FFFF;
DRAWTEXTABS(80,0,'────────────'),Color00FFFF;
DRAWTEXTABS(80,20,'────────────'),Color00FFFF;
DRAWTEXTABS(80,37,'────────────'),Color00FFFF;
DRAWTEXTABS(80,54,'────────────'),Color00FFFF;
DRAWTEXTABS(80,71,'────────────'),Color00FFFF;

大智慧智能分析量能主图指标公式

 

相关文章