在线检测未来函数

通达信中趋势指标公式

来源:Internet,编辑:股旁网,2012-04-09

N1:=5;N2:=10;
STICKLINE(C>0,0,11,15,0),COLOR781816,LINETHICK4;
LC:=REF(CLOSE,1);
RSI5:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*9.8,
COLORGRAY,LINETHICK1;
B:=RSI5<REF(RSI5,1);
IF(B-1,RSI5,DRAWNULL)COLORRED,LINETHICK2;
RSI10:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*10,COLORGRAY;
B1:=RSI10<REF(RSI10,1);
IF(B1-1,RSI10,DRAWNULL)COLOR00AA66,LINETHICK2;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF,LINETHICK6;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00,LINETHICK6;
BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
0,COLORFF00FF,LINETHICK6;
11,COLORFF0000,LINETHICK6;
STICKLINE(UP,0,0.2,3,0),COLOR0000FF,LINETHICK6;
STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00,LINETHICK6;
STICKLINE(BT,0,3,2,0),COLOR000088,LINETHICK6;
STICKLINE(BT,0,3,1,0),COLOR0000CC,LINETHICK6;
STICKLINE(BT,0,3,0.22,0),COLOR0000FF,LINETHICK6;
DRAWTEXT(BT,3,'短牛'),COLOR0000FF,LINETHICK6;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088,LINETHICK2;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA,LINETHICK6;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC,LINETHICK6;
STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF,LINETHICK6;
DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF,LINETHICK6;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,1,5,0),COLOR008888,LINETHICK6;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA,LINETHICK6;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC,LINETHICK6;
STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF,LINETHICK6;
DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF,LINETHICK2;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,9,5,0),COLOR008800,LINETHICK6;
STICKLINE(ST,10,9,2,0),COLOR00AA00,LINETHICK6;
STICKLINE(ST,10,9,1,0),COLOR00CC00,LINETHICK6;
STICKLINE(ST,10,9,0.2,0),COLOR00FF00,LINETHICK6;
DRAWTEXT(ST,9,'卖'),COLOR00FF00,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
VARF1:= TROUGHBARS(3,15,1)<4;
DRAWTEXT(FILTER(VARF1=1,3),1,'●股大涨'),COLORYELLOW;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
YY1:=H=HHV(H,BARSLAST(Q_4)+1);
YY2:=HHV(H,BARSLAST(Q_4)+1);
YY3:=L=LLV(L,BARSLAST(Q_3)+1);
YY4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(YY1,YY2,YY3,YY4,0);
X1:=LLV(Q_2,2)=LLV(Q_2,7) ;
X2:=COUNT(Q_2<0,2);
X3:=CROSS(Q_2,MA(Q_2,2));
X4:=REF(Q_B,1)<REF(Q_B,2);
X5:=Q_A>REF(Q_B,1);
买进:=(X1 AND X2 AND X3) AND X4 AND X5;
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
堪称一绝:IF(REF(TJ,1)=0 AND TJ>=1,2.8,-4),STICK,COLORRED,LINETHICK2;
持币:IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,0,-4),STICK,COLORLIBLUE,LINETHICK2;
地狱底:-4,COLOR0099FF,LINETHICK2;
地狱线:-4,COLORFF1CAE,LINETHICK2;
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5);
AA1:IF(周J<=0 ,-4,0),COLOR00CCCC,LINETHICK3;
DRAWBAND(0,RGB(250,0,0),AA1,RGB(0,0,0));
{WR威}
WR1:(C-LLV(L,N1))/(HHV(H,N1)-LLV(L,N1))*10,COLOR0099FF;
{洗盘再买}
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED;
洗盘再买:IF(黄金 AND RSVV<VARB2-2,5,0),COLORFFAA99,LINETHICK2;

通达信中趋势指标公式

 

相关文章