在线检测未来函数

通达信三彩带MACD指标公式

来源:Internet,编辑:股旁网,2012-04-14

DIF1:=EMA(CLOSE,24) - EMA(CLOSE,52);
DEA1:=EMA(DIF1,18);
MACD1:(DIF1-DEA1)*2,COLORSTICK;
DIF11:=EMA(CLOSE,29) - EMA(CLOSE,68.5);
DEA11:=EMA(DIF11,31);
MACD11:(DIF11-DEA11)*2,COLORSTICK;
DRAWBAND(DIF11,RGB(255,100,230),DEA11,RGB(100,100,255));
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));
DIF:=EMA(CLOSE,6) - EMA(CLOSE,13);
DEA:=EMA(DIF,4.5);
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWBAND(DIF,RGB(500,180,280),DEA,RGB(380,280,180));
STICKLINE(MACD11>0,0,MACD11,1.3,0),COLOR8800FF;
STICKLINE(MACD11<0,0,MACD11,1.3,0),COLORFFFF00;
STICKLINE(MACD1>0,0,MACD1,2,0),COLOR0000DD;
STICKLINE(MACD1<0,0,MACD1,2,0),COLORBLUE;
STICKLINE(MACD>0,0,MACD,0.4,0),COLORYELLOW;
STICKLINE(MACD<0,0,MACD,0.4,0),COLOR00DD00;
DIFFFF:DIF11,COLOR8800FF,LINETHICK0;
DEAAAA:DEA11,COLORFFAA00,LINETHICK0;
DIFFF:DIF1,COLORRED,LINETHICK0;
DEAAA:DEA1,COLORBLUE,LINETHICK0;
DIFF:DIF,COLORYELLOW,LINETHICK0;
DEAA:DEA,COLORGREEN,LINETHICK0;
AA:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
BB:=REF(CLOSE,AA+1)>CLOSE AND DIF1>REF(DIF1,AA+1) AND CROSS(DIF1,DEA1);
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
{www.gupang.com 股旁网_通达信股票指标公式}
二金:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二金,DEA*1.04,15) ;
DRAWTEXT(二金,-0.05,' 2'),COLORFF00FF;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,25);
VAR2:=EMA(VAR1,3);
VAR3:=VAR1>VAR2;
VAR4:=VAR1<VAR2;
STICKLINE(VAR3,VAR1,VAR2,1,0),COLORRED;
STICKLINE(VAR4,VAR1,VAR2,1,0),COLORGREEN;
DRAWICON(V<REF(LLV(V,59),1),0,1);
DRAWICON(V>REF(HHV(V,59),1),0,2);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.12;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低'),COLORWHITE;
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
牛熊分界:0,COLORYELLOW,LINETHICK3,POINTDOT;
STICKLINE(VAR3,VAR1,VAR2,3,0),COLORWHITE;
STICKLINE(VAR4,VAR1,VAR2,1,0),COLORGREEN;

通达信三彩带MACD指标公式

 

相关文章