在线检测未来函数

通达信新微积分主图指标公式

来源:Internet,编辑:股旁网,2012-04-26

ED1:=(-2*REF(C,2)+REF(C,1)+2*C);
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
ED3:=(-0.8*REF(C,4)-0.8*REF(C,3)-0.2*REF(C,2)+0.8*REF(C,1)+2*C);
JF1:SMA(SMA(ED1,3,1),3,1),COLORYELLOW;
JF2:SMA(SMA(ED2,4,1),3,1),COLORWHITE;
BC:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
STICKLINE(A1X>=0,基准,突破,5,0),COLOR000099;
{www.gupang.com 股旁网_通达信股票指标公式}
分水岭:=IF(MA(CLOSE,17)<BC,BC,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
双线持币:HHV(MA(HIGH,(3)),2),LINETHICK2,COLOR00FF00;
单线持股:LLV(MA(HIGH,(3)),1),LINETHICK2,COLOR0000FF;
黑马起飞线:EXPMA(CLOSE,89),COLORWHITE,LINETHICK1;
DRAWBAND(JF1,RGB(255,10,10),JF2,RGB(35,135,30));
DRAWICON(CROSS(ED2,JF2),L/1.001,1);
DRAWICON(CROSS(JF2,ED2),H*1.001,2);
①价:=EMA(CLOSE,16)-EMA(CLOSE,26);
②价:=EMA(①价,9);
MAV:=(C*2+H+L)/4;
SK := EMA(MAV,1) - EMA(MAV,40);
SD := EMA(SK,5);
B:=(SK-SD)*100;
猛牛拉升:=IF(B<-20,-20,IF(B>100,100,B)),COLORRED,LINETHICK2;
STICKLINE(猛牛拉升>=10 AND ①价>②价 AND ①价>REF(①价,1),O,C,3,0),COLORYELLOW;
VL:=REF(LOW,1);
VAR12:=(SMA(ABS(LOW-VL),13,1))/(SMA(MAX(LOW-VL,0),13,1))*100;
VAR14:=MA(VAR12,13);
VAR15:=LLV(LOW,34);
VAR18:=EMA(IF(LOW<=VAR15,VAR14,0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR110*10.9;
T:=FILTER(IF(VAR111<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20);
DRAWTEXT(T,LOW-0.4,'←变盘'),COLORFF00FF;
DRAWTEXT(T,LOW-0.2,'|'),COLORFF00FF;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2)));
DRAWTEXT(BT AND CROSS(VAR111,20),L*0.99,'短牛'),COLOR0000FF;
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
BBB:=AAA-REF(AAA,1);
起爆:=CROSS(BBB,15),COLORWHITE,LINETHICK2;
DRAWTEXT(起爆,L*0.98,'暴'),COLORYELLOW,LINETHICK2;
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VAR5:=HHV(HIGH,34);
趋势:= EMA((VAR3-VAR4)/(VAR5-VAR4)*100,13),LINETHICK2,COLORRED;
人气:=EMA(0.667*REF(趋势,1)+0.333*趋势,2),LINETHICK2,COLORYELLOW;
DRAWTEXT(CROSS(趋势,人气) AND 趋势<15 AND BT AND VAR111>=20,L*0.98,'牛吸'),COLORYELLOW;
发:=(CLOSE*2+HIGH+LOW)/4*10;
孙:=EMA(发,13)-EMA(发,34);
金1:=EMA(孙,5);
顺:=2*(孙-金1)*5.5;
主力拉:=IF(CLOSE<0,0,IF(顺>=0,顺,0)),LINETHICK2,COLOR0000FF;
底部1:=7.0,COLOR70DB93;
前抢:REF(C,BARSLAST(CROSS(主力拉,底部1))),COLOR00FF00,POINTDOT;
DRAWTEXT(CROSS(主力拉,底部1),H,'抢'),COLORYELLOW;
STICKLINE(C,前抢,前抢,8,0)LINETHICK2,COLORCYAN;
B1:=(HHV(H,35)-C)/(HHV(H,35)-LLV(LOW,35))*100-35;
B2:=SMA(B1,35,1)+100;
B3:=(C-LLV(L,35))/(HHV(H,35)-LLV(L,35))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
控盘程度:=(IF(B6>1,B6-1,0))*2.5,COLORRED,LINETHICK2;
控盘上:=IF(控盘程度>REF(控盘程度,1), 控盘程度,DRAWNULL),
STICK,COLORYELLOW,LINETHICK1;
控盘下:=IF(控盘程度<REF(控盘程度,1), 控盘程度,DRAWNULL),
STICK,COLORFF9900,LINETHICK1;
DRAWTEXT(猛牛拉升>=10 AND 控盘下>0,H*1.01,'?'),COLORYELLOW;
DRAWTEXT(控盘上>REF(控盘上,1) AND 控盘程度>100 AND C<REF(C,1)AND C<O,H*1.01,'险'),COLORWHITE;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
A1:=EMA(DIFF,5)*100;
A2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*100;
DRAWTEXT(CROSS(趋势,人气) AND 趋势<40 AND 猛牛拉升>=10 AND A2>A1 ,L,'吸'),COLORYELLOW;
止跌:=(REF(EVERY(C<O,2),1) AND C>O);
VAR1N:=MA(CLOSE,5),;
VAR2N:=MA(CLOSE,10);
VAR3N:=(VAR1N-CLOSE)/CLOSE>3/100;
VAR4N:=(VAR2N-VAR1N)/VAR1N>0.03;
VAR5N:=LLV(CLOSE,30)=LLV(CLOSE,120);
底部:=VAR3N AND VAR4N AND VAR5N;
包赚不赔:=BARSLAST(底部)<=2 AND 止跌;
STICKLINE(包赚不赔,O,C,3,0),COLORMAGENTA;
CCI:=CCI(84),COLORWHITE;
DRAWTEXT(包赚不赔 AND CCI>REF(CCI,1),L,'包'),COLORWHITE;
快枪手:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,LINETHICK2,COLORRED;
STICKLINE(快枪手>0 AND 快枪手>REF(快枪手,1),OPEN,(OPEN+CLOSE)/2,3,0),COLORWHITE;

通达信新微积分主图指标公式

 

相关文章