在线检测未来函数

通达信改进MACD指标公式

来源:Internet,编辑:股旁网,2012-05-14

OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,1);
OBVE:=EMA(OBV,3);
DIFF : EMA(OBVE,12) - EMA(OBVE,26);
BBDIFF:=DIFF-REF(DIFF,1);
DEA : EMA(DIFF,9);
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORYELLOW;
{www.gupang.com 股旁网_通达信股票指标公式}
IF(BBDEA>0,DEA,DRAWNULL),COLOR9966CC;
IF(BBDEA<0,DEA,DRAWNULL),COLOR00FF33;
IF(BBDIFF>0,DIFF,DRAWNULL),COLORWHITE;
IF(BBDIFF<0,DIFF,DRAWNULL),COLORBLUE;

通达信改进MACD指标公式

 

相关文章