在线检测未来函数

通达信龙虎榜MACD指标公式

来源:Internet,编辑:股旁网,2012-08-12

DIF2:EMA(CLOSE,8) - EMA(CLOSE,57),COLORLICYAN;
DEA2:EMA(DIF2,8),COLORWHITE;
MACD:2*(DIF2-DEA2),COLORSTICK;
IF(DIF2>REF(DIF2,1),DIF2,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(DIF2>DEA2,DEA2,DRAWNULL),COLORYELLOW,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORGREEN;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORMAGENTA;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORLIBLUE;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),NODRAW;
DRAWICON(CROSS(50,CCI),DEA2,2);
DRAWICON(CCI>150,DEA2,12);
DRAWTEXT_FIX(1,0.0,0,0,STRCAT('千股千评:',EXTERNSTR(0,1))),COLORRED;
DRAWTEXT_FIX(1,0.6,0,0,STRCAT('业绩预报:',EXTERNSTR(0,14))),COLORYELLOW;
DRAWTEXT_FIX(1,0.0,0.2,0,STRCAT('年报业绩:',EXTERNSTR(0,8))),COLORYELLOW;
DRAWTEXT_FIX(1,0.6,0.2,0,STRCAT('解禁日期:',EXTERNSTR(0,15))),COLORBLUE;
DRAWTEXT_FIX(1,0.0,0.4,0,STRCAT('中报业绩:',EXTERNSTR(0,9))),COLORBLUE;
DRAWTEXT_FIX(1,0.6,0.4,0,STRCAT('主题投资:',EXTERNSTR(0,10))),COLORBROWN;
DRAWTEXT_FIX(1,0.0,0.6,0,STRCAT('机构评级:',EXTERNSTR(0,11))),COLORCYAN;
DRAWTEXT_FIX(1,0.3,0.6,0,STRCAT('智能诊断:',EXTERNSTR(0,12))),COLORRED;
DRAWTEXT_FIX(1,0.0,0.8,0,STRCAT('敢死队席位:',EXTERNSTR(0,13))),COLORLIMAGENTA;

通达信龙虎榜MACD指标公式

 

相关文章