在线检测未来函数

通达信《就要涨停智能选股系统》主力资金指标公式

来源:Internet,编辑:股旁网,2012-09-02

涨幅:=9;高度:=20;跨度:=10;N4:=34;
短线:=EMA(CLOSE,17);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线:=EMA(KKC,50);
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
KDD:=REF(中期,1)<1 AND 中期>1;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
中期线:=MA(持股,12);
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
短期线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30;
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KAAA1:=EXIST(KDD,3);
KBBB1:=C/REF(C,1)>1+0.01*涨幅;
KAAA2:=支撑>中期线 AND 持股=支撑;
KBBB2:=CROSS(C2,C3);
KCCC2:=EXIST(C/REF(C,1)>1+0.01*涨幅,跨度);
KDDD2:=BARSLAST(中期线>短期线)<跨度;
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*涨幅;
KCCC3:=中线/长线<1+0.01*高度;
超级资金1:IF(KAAA1 AND KBBB1,100,0),LINETHICK3,COLORRED;
超级资金2:IF(KAAA2 AND KBBB2 AND KCCC2,100,0),LINETHICK3,COLORYELLOW;
超级资金3:IF(KAAA3 AND KBBB3 AND KCCC3,100,0),LINETHICK3,COLORWHITE;
资金1:REF(中期,1)<1 AND 中期>1,COLORWHITE;
资金2:EXIST(CROSS(C2,C3),2),COLORGREEN;
资金3:支撑>中期线 AND 持股=支撑 AND REF(支撑,2)<REF(持股,2),COLORFF00FF;
资金4:J<D AND DIF>DEA AND REF(J,1)>REF(D,1),COLORYELLOW;
资金5:MACD<0 AND REF(MACD>0,1),COLORRED;
资金6:CROSS(中期线,短期线),COLORGRAY;
STICKLINE(资金1,0,20,3,0),COLORWHITE;
STICKLINE(资金2,20,40,3,0),COLORGREEN;
STICKLINE(资金3,40,60,3,0),COLORFF00FF;
STICKLINE(资金4,60,80,3,0),COLORYELLOW;
STICKLINE(资金5,80,100,3,0),COLORRED;
STICKLINE(资金6,100,120,3,0),COLORGRAY;
STICKLINE(1,0,1,3,0),COLORBLACK;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT_FIX(1,0.01,0.01,0,'超级资金1,出击 V型反转股'),COLORRED;
DRAWTEXT_FIX(1,0.01,0.14,0,'超级资金2,出击涨停回调股'),COLORYELLOW;
DRAWTEXT_FIX(1,0.01,0.27,0,'超级资金3,出击底部拉升股'),COLORWHITE;
DRAWTEXT_FIX(1,0.16,0.01,0,'资金1,出击下降反弹股'),COLORWHITE;
DRAWTEXT_FIX(1,0.16,0.14,0,'资金2,出击二次探底股'),COLORGREEN;
DRAWTEXT_FIX(1,0.16,0.27,0,'资金3,出击强势回调股'),COLORFF00FF;
DRAWTEXT_FIX(1,0.16,0.40,0,'资金4,出击通道回调股'),COLORYELLOW;
DRAWTEXT_FIX(1,0.16,0.53,0,'资金5,出击横盘转强股'),COLORRED;
DRAWTEXT_FIX(1,0.16,0.66,0,'资金6,出击打压转升股'),COLORGRAY;

通达信《就要涨停智能选股系统》主力资金指标公式

 

相关文章