在线检测未来函数

通达信陈琛牵牛指标公式

来源:Internet,编辑:股旁网,2012-10-19

RSV:= (HHV(H,7)-C)/(HHV(H,7)-LLV(L,7))*-20;
LWR1:SMA(RSV,2,1);
LWR2:SMA(LWR1,2,1);
买盘:=EMA(IF(C>O,V/((H-L)*2-ABS(C-O))*(H-L),IF(C<O,V/((H-L)*2-ABS(C-O))*((H-O)+(C-L)),V/2)),2)/(V/10);
卖盘:=EMA(IF(C>O,0-V/((H-L)*2-ABS(C-O))*((H-C)+(O-L)),IF(C<O,0-V/((H-L)*2-ABS(C-O))*(H-L),0-V/2)),2)/(V/10);
和盘:=SMA((SMA((买盘+卖盘),2,1)*6.8),3,1);
TRTR := SUM(MAX(MAX((H+C)/2-L,ABS((H+C)/2-REF((C+L)/2,1))),ABS(L-REF((C+L)/2,1))),10);
HD :=H-REF(H,1);
LD := REF(L,1)-L;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),10);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),10);
PDI:=DMP*100/TRTR;
MDI:=DMM*100/TRTR;
盘和:(3*SMA((SMA((买盘+卖盘),2,1)*6.8),3,1)+(PDI-MDI))/4;
IF(盘和>-8,盘和,-8),COLORF00FF0;
VAR1:=REF((L+O+(C+L)/2+(H+C)/2)/4,1);
VAR2:=SMA(ABS(L-VAR1),13,1)/SMA(MAX(L-VAR1,0),8,1);
VAR3:=MA(VAR2,13);
VAR4:=LLV(L,21);
VAR5:=EMA(IF(L<=VAR4,VAR3,0),3);
洗盘:IF(VAR5<REF(VAR5,1),VAR5,-3),COLORGREEN;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,-3),COLORGREEN;
{ Gupang.com 股-旁-网_通达信股票指标公式}
VAR1C:=EMA(100*((C+L)/2-LLV(L,55))/(HHV(H,55)-LLV(L,55)),13)/4;
VAR1D:=EMA((C+L)/2,2)-EMA((C+L)/2,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*5;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR21:=SQRT(SQRT(L*H*O*(C+L)/2));
VAR22:=EMA(VAR21*0.97,3);
VAR23:=(H+L+(C+L)/2)/3;
VAR24:=(VAR23-MA(VAR23,13))/(0.015*AVEDEV(VAR23,13));
庄拉线:=IF(L<H AND VAR1F>0.015,VAR20,0)/45;
VAR26:=EMA((C+L)/2,2)-EMA((C+L)/2,120);
VAR27:=EMA(VAR26,89);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF( VAR28>0.1,VAR29,0)*2;
量价线:=((C+L)/2-EMA((C+L)/2,21))/EMA((C+L)/2,21)*100;
庄黑线:=(量价线+3*黑马线+6*庄拉线)/10;
VAR2E:=IF(FILTER(量价线>0 AND 量价线<2,3)=1,1,0);
涨幅:=IF(FILTER(庄黑线>0 AND 庄黑线<2 AND VAR2E AND VAR1C<10.38,13)=1,1,0);
选股:=IF(FILTER(VAR2E>0 AND VAR1C<10.38 AND 庄黑线>0 AND 庄黑线<2 AND VAR2E>0,8)=1,1,0);
追涨:IF(FILTER(涨幅 OR 选股,5),5,0),COLORRED;
DRAWICON(追涨>0,选股,1);

通达信陈琛牵牛指标公式

 

相关文章