在线检测未来函数

通达信短线专用指标公式

来源:Internet,编辑:股旁网,2012-11-02

N:=7;M1:=3;M2:=3;P:=12;
LC:=REF(CLOSE,1);
生命线:SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*135,LINETHICK2;
逃顶:135,COLORFFFF00,LINETHICK2;
拉升:=50;
抄底:16,LINETHICK2;
判断:80,COLORYELLOW,LINETHICK2;
换手:=VOL/CAPITAL*100;
十日换手:SUM(换手,10),COLORWHITE,NODRAW;
主力平均成本:( COST(4)),COLORFF00FF,NODRAW;
RS:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RS,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D,COLORFFFF00;
进场:IF(CROSS(J,0) ,100,50),COLORGREEN;
SVOL:=INTPART(SUM(V,0)/CAPITAL);
TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;
S1:=BARSLAST(TJ0)+1;
TJ2:=S1<REF(S1,1);
S2:=IF(TJ2,REF(S1,1)+1,S1);
阶段总额(万):=SUM(AMOUNT/10000,S2)*100,NODRAW;
阶段总量(手):=SUM(V,S2)*100,NODRAW;
阶段成本:(阶段总额(万)/(阶段总量(手)/100)),COLORRED,NODRAW;
开始:=CROSS(生命线,抄底);
走强:=CROSS(生命线,判断);
DRAWICON(开始,抄底+6,1);
DRAWICON(走强,判断+6,11);
YC_买进:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
买进条件:=CROSS(CLOSE,YC_买进) AND YC_买进>REF(YC_买进,1),LINETHICK0;
YC_加仓:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
加仓条件:=CROSS(CLOSE,YC_加仓) AND YC_加仓>REF(YC_加仓,1),LINETHICK0;
DRAWTEXT(买进条件 AND 加仓条件 =1,拉升+6,'买'),COLORRED;
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*5,LINETHICK2,COLORFF00FF;
BB:=RSI>4.1;
CC:=RSI>4.5;
DRAWTEXT(BB,105,'顶')COLORGREEN;
DRAWTEXT(CC,105,'绝顶'),COLORFFFF00;
获利:=WINNER(C)*100,NODRAW;
STICKLINE(获利>99.6,36,16,2,0),COLORGREEN;
STICKLINE(获利>99.6,40,20,2,0),COLORGREEN;
B1:=(((HIGH+LOW)+CLOSE)/3);
B2:=HHV(B1,15);
B3:=LLV(B1,15);
B4:=(B2 - B3);
B5:=(MA(((B1 - B3) / B4),2) * 100);
RSVDD:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
G:=3*SMA(RSVDD,3,1)-2*SMA(SMA(RSVDD,3,1),3,1);
ZXNH:="ZXNH.ZXNH";
买:=B5<3 AND REF(B5,1)=0 AND G<5 AND REF(G,1) <G AND ZXNH;
STICKLINE(买,40,60,1,0),COLORFF00FF;
逃离铁掌帮:=CROSS(CCI,220) ;
{STICKLINE(逃离铁掌帮,2,30,2.7,0),COLOR003300;
STICKLINE(逃离铁掌帮,2,30,1.8,0),COLOR007700;
STICKLINE(逃离铁掌帮,2,30,0.9,0),COLOR00BB00;}
STICKLINE(逃离铁掌帮,16,30,2,0),COLOR00FF00;
DRAWTEXT(逃离铁掌帮,40,'绝情谷'),COLORFFFFFF;
探针1:=0.01*MA(AMOUNT,13)/MA(VOL,13);
探针2:=(CLOSE-探针1)/探针1*100,COLORRED,LINETHICK1;
DRAWTEXT("ZXNH.ZXNH"=1 AND 探针2<=-2,128,'买'),COLORFF00FF;
DRAWTEXT("ZXNH.ZXNH"=1 AND 探针2>2,126,'卖'),COLORGREEN;
CCC:=CROSS(H,MA(L+(H-L)/2,25)*1.15);DDDWWW:=CROSS(H,MA(L+(H-L)/2,25)*1.25);
DRAWTEXT(CCC AND MA(L+(H-L)/2,75)>=REF(MA(L+(H-L)/2,75),1),130,'卖吧'),COLOR6699FF;
DRAWTEXT(DDDWWW AND MA(L+(H-L)/2,75)>=REF(MA(L+(H-L)/2,75),1),120,'逃顶'),COLOR6699FF;
DRAWTEXT(CCC AND MA(L+(H-L)/2,75)<=REF(MA(L+(H-L)/2,75),1),130,'逃命'),COLORWHITE;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,P))/(0.015*AVEDEV(TYP,P));
秒杀CCI:=EMA((TYP-MA(TYP,P))/(0.015*AVEDEV(TYP,P)),2.0332),COLORWHITE;
STICKLINE(秒杀CCI<-150,40,20,0.5,0),COLORRED;
STICKLINE(秒杀CCI>150,110,120,1,0),COLORFFFF00;
DRAWICON(CROSS(CCI,-130) ,40,23);
RSV:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
涨幅:=(H-REF(C,1))/(REF(C,1))*100;
跌幅:=(-(REF(C,1)-L)/(REF(C,1)))*100,LINETHICK0;
振幅:=涨幅+(-跌幅);
真实振幅:=(REF(振幅,1))-(REF(振幅,2))+(REF(振幅,1)),COLORRED;
真实涨跌幅:=(REF(C,1)-C)/REF(C,1)*-100,LINETHICK0;
KWW:=SMA(RSV,3,1);DWW:=SMA(KWW,3,1);JWW:=3*KWW-2*DWW,LINETHICK0;
明天可能涨停:=IF(REF(O>C,1) {AND 跌幅>=-4.2 AND REF(跌幅,1)<-3.5} AND 真实振幅>13 AND 振幅>=5 AND 振幅<REF(振幅,1) AND JWW<20,5,0)COLORMAGENTA;
DRAWTEXT( 明天可能涨停,120,'明大涨'),COLORFF00FF;
VARB2:=(RS/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED;
低买:=IF(黄金 AND RS<VARB2-2,50,0),COLORYELLOW,LINETHICK2;
STICKLINE(低买,120,105,1.5,0),COLORYELLOW;
M:=14;Q:=6;
MM:=IF(PERIOD=1,M,IF(PERIOD=2,M,IF(PERIOD=3,M,IF(PERIOD=4,M,IF(PERIOD=5,M,IF(PERIOD=6,Q,IF(PERIOD=7,Q,IF(PERIOD=8,Q,0))))))));
AVG:=(HIGH+LOW+CLOSE)/3;
CCIWW:=(AVG-MA(AVG,MM))/(0.015*AVEDEV(AVG,MM));
DRAWICON((CCIWW)>=200,98,35);
TJ1:=(MIN(C,O)-L)/(H-L)>=0.5;
TJ2W:=L/MIN(C,O)<=0.99;
TJ3:=(C-MA(C,30))/MA(C,30)*100<-3;
TJ4:=C>O;
XG:=TJ1 AND TJ2W AND TJ3 AND TJ4;
STICKLINE(XG,70,40,0.1,0)COLORYELLOW;
LB:=V/(REF(V,15)/5);
DIFQ:=EMA(LB,30)-EMA(LB,60);
DEAQ:=EMA(DIFQ,15);
MALB:=(DIFQ-DEAQ)*2;
{换手部分}
HS:=HSL;
HS60:=MA(HS,60);
MA120:=MA(LB,120)/10;
NIU:=CROSS(MALB,MA120) AND C>REF(C,1);
HS5W:=MA(HS,5);
STICKLINE(CROSS(HS5W,HS60) AND C>REF(C,1) AND NIU,80,60,1,0),COLORFF2400;
VARAWW:=(HIGH - LOW);
VARB1:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VARB1 / VARAWW) * VOL);
VAR7:=((VAR4 / VARAWW) * VOL);
VAR8:=((VAR5 / VARAWW) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARBW:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARBW)),110,'◆强2天'),COLORFF00FF;
VAR2:=LOW;
VAR3:=HIGH;
警戒线:= 2.8;
减仓线:= 3.2 ;
卖出线:= 3.5;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
DRAWTEXT(CROSS(动力线,减仓线),120,'注意风险!!');
DRAWTEXT(CROSS(动力线,卖出线),110,'出局 ');
MA9:=EMA(CLOSE,9);
LUP:=EXPMA(MA9*1.14,5);
XGW:=CLOSE>LUP AND C>REF(C,1)*(1+9.96/100) AND C=H;
DRAWTEXT (XGW,95,'小心'),COLORGREEN;
信号:=COUNT(REF(EMA(C,3),1)<REF(EMA(C,3),2),5)=5
AND EMA(C,3)>REF(EMA(C,3),1) ;
DRAWICON(信号,103,25);
快线:=EMA((CLOSE+LOW)/2,8);
均衡:=EMA(EMA((CLOSE+LOW)/2,20),8);
DRAWTEXT(CROSS(快线,均衡),120,'减仑'),COLOR00FF00;
LONGGGG发财线:=38,COLORFF3311;
LONGGGG趋势线:=51,COLORFF1155;
OK:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,LINETHICK2,COLORRED;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORFFFFFF;
RSI3:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORFFFFFF;
RSI4:=SMA(RSI3,7,1),LINETHICK2,COLOR00CD00;
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK2;
W1:=MA(趋势A,7)*1.372,COLORRED,LINETHICK2;
W2:=W1*1.0887;
W3:=(1.5*(趋势B+RSI4)-(W2+W1))+12,COLOR3377FF,COLORRED,LINETHICK2,COLORFF0000;
W4:IF((CROSS(W1,趋势C) OR CROSS(W1,W3) AND W3<LONGGGG发财线 AND RSI2<LONGGGG趋势线),100,38 ),LINETHICK2,COLORFF6655;
启动:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,W3) AND W3<LONGGGG发财线 AND RSI1<LONGGGG趋势线),100,38 ),LINETHICK2,COLORFF6655;
DRAWICON(CROSS(RSI1,启动), RSI1,1 );

通达信短线专用指标公式

 

相关文章