在线检测未来函数

通达信板块涨跌幅指标公式

来源:Internet,编辑:股旁网,2012-11-20

VAR1:=("399139$C");
VAR2:=("399190$C");
VAR3:=("399132$C");
VAR4:=("399150$C");
VAR5:=("399138$C");
VAR6:=("399200$C");
VAR7:=("399110$C");
VAR8:=("399136$C");
VAR9:=("399135$C");
VAR10:=("399130$C");
VAR11:=("399160$C");
VAR12:=("399131$C");
VAR13:=("399137$C");
VAR14:=("399140$C");
VAR15:=("399210$C");
水电:(VAR14/REF(VAR14,1)-1)*100,NODRAW,COLORFFFF00;
服务:(VAR15/REF(VAR15,1)-1)*100,NODRAW,COLORFF66CC;
金融:(VAR2/REF(VAR2,1)-1)*100,NODRAW,COLOR00FFFF;
地产:(VAR6/REF(VAR6,1)-1)*100,NODRAW,COLORAAAAFF;
石化:(VAR9/REF(VAR9,1)-1)*100,NODRAW,COLORFF99BB;
金属:(VAR13/REF(VAR13,1)-1)*100,NODRAW,COLORFFFF66;
医药:(VAR1/REF(VAR1,1)-1)*100,NODRAW,COLOR0033FF;
机械:(VAR5/REF(VAR5,1)-1)*100,NODRAW,COLORFFCC00;
电子:(VAR8/REF(VAR8,1)-1)*100,NODRAW,COLOR00BBFF;
制造:(VAR10/REF(VAR10,1)-1)*100,NODRAW,COLORCCCCCC;
农林:(VAR7/REF(VAR7,1)-1)*100,NODRAW,COLOR33FF66;
运输:(VAR11/REF(VAR11,1)-1)*100,NODRAW,COLORFFFFFF;
纺织:(VAR3/REF(VAR3,1)-1)*100,NODRAW,COLORCC66FF;
建筑:(VAR4/REF(VAR4,1)-1)*100,NODRAW,COLOR009999;
食品:(VAR12/REF(VAR12,1)-1)*100,NODRAW,COLOR6666FF;
P1:=IF(BARSLAST(CURRBARSCOUNT=1),1,0);
P2:=IF(BARSLAST(CURRBARSCOUNT=5),1,0);
P3:=IF(BARSLAST(CURRBARSCOUNT=10),1,0);
P4:=IF(BARSLAST(CURRBARSCOUNT=15),1,0);
P5:=IF(BARSLAST(CURRBARSCOUNT=20),1,0);
P6:=IF(BARSLAST(CURRBARSCOUNT=25),1,0);
P7:=IF(BARSLAST(CURRBARSCOUNT=30),1,0);
P8:=IF(BARSLAST(CURRBARSCOUNT=35),1,0);
P9:=IF(BARSLAST(CURRBARSCOUNT=40),1,0);
P10:=IF(BARSLAST(CURRBARSCOUNT=45),1,0);
P11:=IF(BARSLAST(CURRBARSCOUNT=50),1,0);
P12:=IF(BARSLAST(CURRBARSCOUNT=55),1,0);
P13:=IF(BARSLAST(CURRBARSCOUNT=60),1,0);
P14:=IF(BARSLAST(CURRBARSCOUNT=65),1,0);
P15:=IF(BARSLAST(CURRBARSCOUNT=70),1,0);
P16:=IF(BARSLAST(CURRBARSCOUNT=75),1,0);
食品0:IF(1=1,IF(P2-P1,CONST(食品),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR6666FF;
建筑0:IF(1=1,IF(P3-P2,CONST(建筑),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR009999;
纺织0:IF(1=1,IF(P4-P3,CONST(纺织),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORCC66FF;
运输0:IF(1=1,IF(P5-P4,CONST(运输),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFFFFFF;
农林0:IF(1=1,IF(P6-P5,CONST(农林),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR33FF66;
制造0:IF(1=1,IF(P7-P6,CONST(制造),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORCCCCCC;
电子0:IF(1=1,IF(P8-P7,CONST(电子),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR00BBFF;
机械0:IF(1=1,IF(P9-P8,CONST(机械),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFFCC00;
医药0:IF(1=1,IF(P10-P9,CONST(医药),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR0033FF;
金属0:IF(1=1,IF(P11-P10,CONST(金属),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFFFF66;
石化0:IF(1=1,IF(P12-P11,CONST(石化),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFF9988;
地产0:IF(1=1,IF(P13-P12,CONST(地产),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORAAAAFF;
金融0:IF(1=1,IF(P14-P13,CONST(金融),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLOR00FFFF;
服务0:IF(1=1,IF(P15-P14,CONST(服务),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFF66CC;
水电0:IF(1=1,IF(P16-P15,CONST(水电),DRAWNULL),DRAWNULL),STICK,LINETHICK6,
COLORFFFF00;
DRAWTEXT(P2-P1,0,'食品'),COLOR6666FF;
DRAWTEXT(P3-P2,0,'建筑'),COLOR009999;
DRAWTEXT(P4-P3,0,'纺织'),COLORCC66FF;
DRAWTEXT(P5-P4,0,'运输'),COLORFFFFFF;
DRAWTEXT(P6-P5,0,'农林'),COLOR33FF66;
DRAWTEXT(P7-P6,0,'制造'),COLORCCCCCC;
DRAWTEXT(P8-P7,0,'电子'),COLOR00BBFF;
DRAWTEXT(P9-P8,0,'机械'),COLORFFCC00;
DRAWTEXT(P10-P9,0,'医药'),COLOR0033FF;
DRAWTEXT(P11-P10,0,'金属'),COLORFFFF66;
DRAWTEXT(P12-P11,0,'石化'),COLORFF99BB;
DRAWTEXT(P13-P12,0,'地产'),COLORAAAAFF;
DRAWTEXT(P14-P13,0,'金融'),COLOR00FFFF;
DRAWTEXT(P15-P14,0,'服务'),COLORFF66CC;
DRAWTEXT(P16-P15,0,'水电'),COLORFFFF00;

通达信板块涨跌幅指标公式

 

相关文章