在线检测未来函数

通达信相牛观势主图指标公式

来源:Internet,编辑:股旁网,2012-11-28

N:=5;
SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
ENTERLONG:CROSS(SJ,ZJ) AND SJ<30,COLORRED;
EXITLONG:CROSS(ZJ,SJ) AND SJ>70,COLORGREEN;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:=R1>REF(R1,1);
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1);
NOTEXT1:DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;
NOTEXT2:DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;
必卖止损价位:MA(C,14),COLORLIRED,CROSSDOT,LINETHICK3;
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR3:=LLV(LOW,5);
VAR4:=HHV(HIGH,4);
散户:=EMA((VAR1-VAR3)/(VAR4-VAR3)*100,4)*VAR2;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR2;
DRAWTEXT(CROSS(散户,庄家) AND 散户<47,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>60,H+0.05,'←高抛'),COLOR80FF00;
{DRAWICON(CROSS(散户,庄家) AND 散户<47,L-0.05,4);
DRAWICON(CROSS(庄家,散户) AND 散户>60,H+0.05,5);}
{市场成本:DMA(AMOUNT/V/100,V/CAPITAL),COLORRED;}
操盘成本:=(MA(C,30)+MA(C,72))/2,COLORRED;
市盈率:=DYNAINFO(39),COLORFF00FF;
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
STICKLINE(TJ,OPEN,CLOSE,3,0),COLORFF00FF;
量_价:=1;CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;
TJB:=ZZ<=MIN(C,O) AND CTKG=1;
ZF:=IF(TJA,1,IF(TJB,-1,0));
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);{一字涨停};
TJ2:=H=L AND C<REF(C,1);{一字跌停};
TJ3:=H=L AND C=REF(C,1);{连续一字涨、跌停};
量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;{平盘量,白色}
EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
差:=(JGL_DX*量_价)/20000,COLOR13AADD;
DX:=JGL_DX*100;
买:=量_价*(1+JGL_DX)/20000,COLOR1133AA;
卖:=量_价*(1-JGL_DX)/20000,COLORFFFF00;
量差:=买-卖,COLORYELLOW;
STICKLINE(量差<=0,CLOSE,OPEN,3,0),COLOR009900;
STICKLINE(量差<=0,CLOSE,OPEN,2,0),COLOR00BB00;
STICKLINE(量差<=0,CLOSE,OPEN,1,0),COLOR00DD00;
STICKLINE(量差<=0,CLOSE,OPEN,0.1,0),COLOR00FF00;
STICKLINE(量差>=0,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(量差>=0,CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE(量差>=0,CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE(量差>=0,CLOSE,OPEN,0.1,0),COLORCC66FF;
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
STICKLINE(V2V,OPEN,CLOSE,2,0),COLORYELLOW;
ZT:=C/REF(C,1)>1.097;
STICKLINE(ZT,OPEN,CLOSE,2,0),COLORYELLOW;
V3V:=V/REF(V,1)>=1.9 AND C<REF(C,1);
STICKLINE(V3V,OPEN,CLOSE,2,0),COLORBLUE;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'↖抄底'),COLORRED;
AR1:=REF(CLOSE,1);
AR2:=SMA(MAX(CLOSE-AR1,0),7,1)/SMA(ABS(CLOSE-AR1),7,1)*100;
DRAWTEXT(FILTER(REF(AR2,1)<20 AND AR2>REF(AR2,1),5),L*0.99,'↖特准抄底'),COLORGREEN;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9.5,L*0.96,'↖红柱抄底'),COLORRED;
EMA4:EMA(C,4),COLORWHITE,LINETHICK2;
EMA24:EMA(C,24),COLORGREEN,LINETHICK2;
EMA34:EMA(C,34),COLORYELLOW,LINETHICK2;
EMA60:EMA(C,60),COLORBLUE,LINETHICK2;
K:=(C+H+L)/3;
DD:=MA(K,4);
{操作:DD,COLORWHITE,LINETHICK2;
拉升:HHV(DD,13),COLORRED,LINETHICK2;
阻力:HHV(DD,55),COLORRED;
买卖:LLV(DD,8),COLORYELLOW,LINETHICK2;
顶部:HHV(H*0.98,55),COLORYELLOW;}
DRAWTEXT(REF(C,1)>DD AND C<DD AND DD>REF(DD,1),H*1.02, '←卖');
DRAWTEXT(REF(C,1)<DD AND C>DD AND DD<REF(DD,1),L*0.98, '←买'),COLORWHITE;
{STICKLINE( MA(CLOSE,8)>MA(CLOSE,30),MA(CLOSE,8),MA(CLOSE,30),8,0),COLOR000088;
STICKLINE( MA(CLOSE,8)<MA(CLOSE,30),MA(CLOSE,8),MA(CLOSE,30),8,0),COLOR008800;};
RC1:=REF(C,1);
涨停率10:=10-1/RC1;
涨停率5:=5-1/RC1;
比前涨率:=(C-RC1+0.004)*100/RC1;
比前跌率:=(RC1-C-0.004)*100/RC1;
ST:=NAMELIKE('ST') OR NAMELIKE('*ST');
涨停:= IF(ST, (比前涨率>=涨停率5), (比前涨率>=涨停率10));
跌停:= IF(ST, (比前跌率>=涨停率5), (比前跌率>=涨停率10));
盘中涨停:=(H-RC1+0.004)*100/RC1>=IF(ST, 涨停率5,涨停率10);
盘中跌停:=(RC1-L-0.004)*100/RC1>=IF(ST, 涨停率5,涨停率10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLOR007700;{跌停后回升}
STICKLINE(涨停,O,C,1,0),COLORRED;
STICKLINE(跌停,O,C,1,0),COLORLICYAN;
本日涨率:=(C-O+0.004)*100/O;
本日跌率:=(O-C-0.004)*100/O;
大阳线:=C>O AND (比前涨率>=涨停率5 OR 本日涨率>=涨停率5)
AND 比前涨率<涨停率10 AND 涨停=0;
STICKLINE(大阳线,O,C,1,0),COLOR0000BB;
大阴线:=C<O AND (比前跌率>=涨停率5 OR 本日跌率>=涨停率5)
AND 比前跌率<涨停率10 AND 跌停=0;
STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,0,0),COLORRED;{假阴柱};
DRAWTEXT_FIX(1,0.18,0.06,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.25,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.45,8,0,'『财神705制作』'),COLOR4B4B4B,LINETHICK3;

通达信相牛观势主图指标公式

 

相关文章