在线检测未来函数

通达信OBV+MACD指标公式

来源:Internet,编辑:股旁网,2012-12-14

OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0))/25000,0),1);
OBVE:=EMA(OBV,3);
DIFF : EMA(OBVE,12) - EMA(OBVE,26),LINETHICK2;
BBDIFF:=DIFF-REF(DIFF,1);
DEA : EMA(DIFF,9),LINETHICK2;
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,3,1),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,1),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,3,1),COLORYELLOW;
IF(BBDEA>0,DEA,DRAWNULL),COLOR9966CC,LINETHICK2;
IF(BBDEA<0,DEA,DRAWNULL),COLOR00FF33,LINETHICK2;
IF(BBDIFF>0,DIFF,DRAWNULL),COLORRED,LINETHICK2;
IF(BBDIFF<0,DIFF,DRAWNULL),COLORCYAN,LINETHICK2;

通达信OBV+MACD指标公式

 

相关文章