在线检测未来函数

大智慧潜筹涌动指标公式

来源:Internet,编辑:股旁网,2012-12-22

input:SW(18,11,111),BW(66,33,111),DW(86,55,99);
DN:=INTPART(276/POW(DATATYPE-1.7,2)-1.1);
DS:=if(DN>4.8,intpart(DN/5),1);
CJ:=(H+L+2*O+3*C)/7;
KN:=POW(HHV(H,18*DS)/HHV(H,0),0.9);
短筹:SMA(SMA((PWINNER(2*SW,BW*CJ/100)+0.618*PWINNER(SW,DW*CJ/100))*61.8,6*DS,2*DS),11*DS,11*DS-1),coloryellow;
抢筹:if(slope(短筹,2*DS)>=0,slope(短筹,2*DS)*POW(0.61*DN,1.5),0),color00b0ff;
活筹:=0.28*短筹+4.62*抢筹-3;
上涨角:=HHV(atan(slope(活筹,3*DS)*0.58)*180/3.14159,3*DS);
TT:=(上涨角+1.11*短筹)/1.916;
屯:=SMA(TT,12*DS,3*DS);
屯筹:(2.28*HHV(屯,8*DS)+SMA(屯,12*DS,1))/2.801;
PARTLINE(屯筹,slope(屯筹,2)>0,RGB(255,0,0),slope(屯筹,2)<=0,RGB(255,255,255),1,RGB(0,0,255));
QL:=(抢筹*0.8+slope(短筹,2*DS)*(60-短筹)*0.8+slope(屯筹,3*DS)*(88-屯筹)*0.55+slope(屯,3*DS)*(屯-100)*0.2)*pow(1.19*DS,0.4)*KN;
潜筹:if(slope(QL,8*DS)>0,0.22*SMA(QL,12*DS,12*DS-1)+0.44*HHV(QL,8*DS)-4,0),DOTLINE,colorff9977;{分析家去DOTLINE}
QF:=BARSLAST(cross(68,潜筹))+1;
潜伏期:if(QF=1,ref(QF,1)+1,QF),linethick0;
潜深:=0.5*HHV(潜伏期,18*DS)+0.5*SMA(潜伏期,18*DS,1);
上浮力:if(slope(潜深,2)<0,KN*50*pow(-slope(潜深,2),0.2),0),COLORMAGENTA,linethick2;
KP:=BARSLAST(cross(短筹,屯筹*(KN-0.0495)))+1;
庄筹派发:SMA(MA(115*KN-屯筹*(KN-0.0495),KP)*0.6,9*DS,2)+25,colorwhite;
潜筹涌动:=SMA(潜筹,9*DS,2);
XG:=sma(V,4,3)<1.421*sma(V,24,1);
牛市粗选:屯筹>88 and 庄筹派发<46.7 and 0.495*潜筹涌动+潜伏期>18.2 and XG ,linethick0;
refline:0,60,80,100;
回头岸:-潜筹*slope(潜筹,2)/100,linethick0;
定军山:抢筹+slope(屯筹,8),linethick0;
熊市粗选:(回头岸>0.1 OR 定军山>0) and C/REF(C,1)>=1.048 AND 潜筹涌动>0.3*潜筹 AND XG,linethick0;

大智慧潜筹涌动指标公式

 

相关文章