在线检测未来函数

通达信风雨组合指标公式

来源:Internet,编辑:股旁网,2013-03-05

Var1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
山峰: SMA(Var1,5,1)-8,LINETHICK2,COLORCYAN;
STICKLINE(山峰,0,山峰,1,0),COLORC8FF00;
Var2:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
Var3:=SMA(Var2,5,1)-16;
STICKLINE(Var3>山峰,0,-5,4,2),COLORYELLOW;
STICKLINE(Var3<山峰,0,-5,4,2),COLOR9800FF;
山谷: STICKLINE(FILTER(CROSS(Var3,山峰),5)=1 AND 山峰<15,0,30,13,2),COLORgreen;
DRAWTEXT(FILTER(CROSS(Var3,山峰),5)=1 AND 山峰<15,-12,'山谷'),COLORgreen;
山腰: STICKLINE(CROSS(山峰,Var3) AND Var3>=55 AND Var3<70,0,50,13,0),COLORYELLOW;
DRAWTEXT(CROSS(山峰,Var3) AND Var3>=55 AND Var3<70,-12,'小歇'),COLORYELLOW;
山顶: STICKLINE(FILTER(CROSS(山峰,80),20)=1,0,65,13,0),COLORred;
DRAWTEXT(FILTER(CROSS(山峰,80),20)=1,-12,'山顶'),COLORred;
大本营: -20,CIRCLEDOT,COLOR3098FF;
Z001:=SMA(Vol,5,1);
Z002:=(Z001-llv(Z001,10))/(hhv(Z001,10)-llv(Z001,10))*100;
Z003:=SMA(Z002,3,1);
Z004:=100-Z003;
Z005:=REF(Z004,1)>REF(Z004,2) AND Z004<34;
Z006:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Z007:=FILTER(Z005,3);
群山:=SMA(Z006,3,1),LINESTICK, COLORBLUE;
下山了:STICKLINE(Z007 AND 群山>60,0,75,13,0),colormagenta;
DRAWTEXT(Z007 AND 群山>60,-12,'下山了'),colormagenta;

通达信风雨组合指标公式

 

相关文章