在线检测未来函数

通达信拂晓黄昏主图指标公式

来源:Internet,编辑:股旁网,2013-03-17

M1:=5;M2:=10;M3:=20;M4:=60;M5:=120;
MA1:MA(CLOSE,M1),COLORYELLOW;
MA2:MA(CLOSE,M2),COLORMAGENTA;
MA3:MA(CLOSE,M3),COLORGREEN;
MA4:MA(CLOSE,M4),COLORFFFFFF;
MA5:MA(CLOSE,M5),COLORRED;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)) AND C=H,1,0);
STICKLINE(涨停,O,C,2.5,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,1),COLORYELLOW;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)) AND C=L,1,0);
STICKLINE(跌停,O,C,2.5,0),COLORFFFFFF;
STICKLINE(跌停,H,L,0,1),COLORFFFFFF;
涨幅:100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORWHITE;
最大涨幅:100*(H-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORYELLOW;
最大跌幅:100*(L-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORYELLOW;
实体幅:ABS(100*(CLOSE-OPEN)/OPEN),NODRAW,COLORRED;
上影幅:IF(CLOSE>OPEN,100*(H-C)/C,100*(H-O)/O),NODRAW,COLORYELLOW;
下影幅:IF(CLOSE>OPEN,100*(O-L)/L,100*(C-L)/L),NODRAW,COLORWHITE;
X:=(3*C+L+O+H)/6;
AH1:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210;
CP:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
AH2:=EXPMEMA(CP,25);
持股线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR2M:=CLOSE*VOL;
VAR3M:=EMA((EXPMA(VAR2M,3)/EXPMA(VOL,3)+EXPMA(VAR2M,6)/EXPMA(VOL,6)+EXPMA(VAR2M,12)/EXPMA(VOL,12)+EXPMA(VAR2M,24)/EXPMA(VOL,24))/4,13);
SDN:=VAR3M*0.94;
涨停B:=CLOSE>1.1*REF(CLOSE,1)-0.005 AND H>L;
首个涨停:=BARSLAST(涨停B);
大阳:=100*(H-REF(C,1))/REF(C,1)>7;
DRAWICON((C>SDN AND 100*(L-持股线)/持股线<1.5 AND 100*(L-((MIN(AH2,AH1)+MIN(持股线,AH2)+MIN(持股线,AH1))/2.95))/((MIN(AH2,AH1)+MIN(持股线,AH2)+MIN(持股线,AH1))/2.95)<1.5 AND (COUNT(大阳{ OR 倍量},13)>=2 OR 首个涨停<13) AND BARSLAST(大阳)>0 AND 涨幅<=2),L*0.98,1);
DRAWTEXT(CLOSE>1.1*REF(CLOSE,1)-0.005,CLOSE*1.02,'停,'),COLORCYAN;
DRAWTEXT(CLOSE<0.9*REF(CLOSE,1)+0.005,L*0.98,'停,'),COLORCCCCCC;
VAR32:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*10;
火:=BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1));
CRXP:=((REF(上影幅,1)>3 AND REF(下影幅,1)<1.15))
AND ((下影幅>3 AND 上影幅<1.55)) AND 涨幅<8;
JM:=(3*SMA(SMA(VAR32,2,1),2,1)-2*SMA(SMA(SMA(VAR32,2,1),2,1),3,1));
强势回调:=(首个涨停<14 OR (首个涨停<26 AND 首个涨停>19));
搓揉:=((强势回调 AND CRXP) OR (CRXP AND (JM>REF(JM,1) OR (火>0 AND JM<7))));
DRAWTEXT(搓揉,L*0.98,'搓揉,'),COLORYELLOW;
回调搓合承受价:(MIN(AH2,AH1)+MIN(BBI,AH2)+MIN(BBI,AH1))/2.95,NODRAW;
大盘短期生命线:EMA(((SLOPE(INDEXC,22)*23)+INDEXC),48),COLORYELLOW,LINETHICK3,NODRAW;
DRAWTEXT(LLV(100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6),2)=LLV(100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6),7) AND COUNT(100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)<0,2) AND CROSS(100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6),MA(100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6),2)),LOW*0.98,'拂晓'),COLORYELLOW;
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=CROSS(79,VAR2);
VAR4:=FILTER(VAR3,4);
DRAWTEXT(VAR4,(H*1.03),'黄昏'),COLORYELLOW;

通达信拂晓黄昏主图指标公式

 

相关文章