在线检测未来函数

通达信复合周期MACD指标公式

来源:Internet,编辑:股旁网,2013-04-26

使用经验:如果是周金叉比月金叉要前的话,就很可能是月周共振成功的概率非常大。如果月金叉比周金叉要前的话,那就有可能不共振。但是至少短线共振力度很明显的。如果MACD与KDJ在周K共振的话一周就可以确定下来了。

DRAWGBK(1>0, RGB(50,100,80),RGB(100,50,100),0,'',0);
DIFW:"MACD.DIF#WEEK",COLORYELLOW;
DEAW:"MACD.DEA#WEEK",COLORWHITE;
DIFM:="MACD.DIF#MONTH",COLORMAGENTA;
DEAM:="MACD.DEA#MONTH",COLORGREEN;
DRAWBAND(DIFW,RGB(200,200,0),DEAW,RGB(0,0,200));
MACD:("MACD.DIF#WEEK"-"MACD.DEA#WEEK")*2,COLORSTICK;
M周叉:=IF(CROSS(DIFW,DEAW),1,0),COLORRED,NODRAW;
M月叉:=IF(CROSS(DIFM,DEAM),1,0),COLORCYAN,NODRAW;
DRAWTEXT(M周叉=1,DIFW,'MACD周'),COLOR8000FF;
DRAWTEXT(M月叉=1,DEAW,'MACD月'),COLORCYAN;
{KDJ复合}
AA:="KDJ.K#WEEK";
BB:="KDJ.D#WEEK";
AAA:="KDJ.K#MONTH";
BBB:="KDJ.D#MONTH";
K周叉:=IF(CROSS(AA,BB),1,0),COLORRED;
K月叉:=IF(CROSS(AAA,BBB),1,0),LINETHICK2,COLORCYAN;
MK周共振:IF(M周叉=1 AND K周叉=1,0,DEAW),COLORLICYAN;
DRAWTEXT(MK周共振=0,0,'MK周共振'),COLORYELLOW;
MK月共振:IF(M月叉=1 AND K月叉=1,1,0),NODRAW;
DRAWTEXT(MK月共振=1,MACD,'MK月共振'),COLORYELLOW;
M周月共振:IF((EXIST(M月叉=1,21) AND M周叉=1) OR (EXIST(M周叉=1,21) AND M月叉=1),0,DIFW),COLORYELLOW;
DRAWTEXT((EXIST(M月叉=1,21) AND M周叉=1) OR (EXIST(M周叉=1,21) AND M月叉=1),0,'M周月共振'),COLORWHITE;

通达信复合周期MACD指标公式

 

相关文章