在线检测未来函数

通达信降龙七式主图指标公式

来源:Internet,编辑:股旁网,2013-05-12

{出轨道}
N:=13;P1:=80;P2:=100;
VAR2:=CLOSE*VOL;
VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,24)/EXPMA(VOL,24))/4,N);
VAR4:=EXPMA(CLOSE,9);
上轨:EXPMA(VAR4*1.11,5),COLORGREEN,NODRAW;
下轨:EXPMA(VAR4*0.89,5),COLORMAGENTA,NODRAW;
DRAWBAND(MA(CLOSE,10),RGB(100,50,50),上轨,RGB(100,50,50));
DRAWBAND(MA(CLOSE,10),RGB(0,60,100),下轨,RGB(0,60,100));
STICKLINE(MA(C,30)<MA(C,20)AND MA(C,20)<MA(C,10)AND MA(C,10)<MA(C,5),MA(CLOSE,10),下轨,0,4),COLORBLUE;
STICKLINE(MA(C,30)<MA(C,20)AND MA(C,20)<MA(C,10)AND MA(C,10)<MA(C,5),下轨*1.01,下轨,4,0),COLORRED,LINETHICK4;
STICKLINE(C>MA(CLOSE,10) ,H,L,0,0),COLORRED;
STICKLINE(C>MA(CLOSE,10) ,O,C,3,1),COLORRED;
STICKLINE(C>MA(CLOSE,10)AND C<=O ,H,L,0,0),COLORGREEN;
STICKLINE(C>MA(CLOSE,10)AND C<=O ,O,C,3,1),COLORGREEN;
STICKLINE(C<=MA(CLOSE,10) ,H,L,0,0),COLORBROWN;
STICKLINE(C<=MA(CLOSE,10) ,O,C,3,1),COLORBROWN;
STICKLINE(上轨>LOW AND 上轨<HIGH,上轨,MAX(上轨,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(上轨>MIN(C,O) AND 上轨<MAX(C,O),上轨,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(上轨>LOW AND 上轨<HIGH,上轨,HIGH,0,0),COLORGREEN;
STICKLINE(上轨<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(上轨<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(下轨>LOW AND 下轨<HIGH,下轨,MIN(MIN(OPEN,CLOSE),下轨),3,0),COLORMAGENTA;
STICKLINE(下轨>MIN(C,O) AND 下轨<MAX(C,O),下轨,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(下轨>LOW AND 下轨<HIGH,下轨,LOW,0,0),COLORMAGENTA;
STICKLINE(下轨>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(下轨>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
{短线主图}
MA6:=MA(C,5),COLORWHITE;
买进价:=((C-REF(MA6,1))/6+MA6)*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1)AND C>MA(CLOSE,10);
STICKLINE(买进条件,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(买进条件,O,C,2,0),COLORYELLOW,LINETHICK2;
{趋势线}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,26)*15+C,45);
BU:=CROSS(买线,卖线);
趋势线:MA(CLOSE,10),COLORYELLOW,LINETHICK2;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;
SEL:=CROSS(卖线,买线);
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:=SMA(JC,5,1),COLORCYAN;
价:=IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
十日乖离:(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*100,COLORYELLOW,NODRAW;
STICKLINE(十日乖离>30,MA(CLOSE,10)*1.3,MA(CLOSE,10)*1.305,8,0),COLORYELLOW;
{主题投资}
DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.00,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORYELLOW;
{主力进出}
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.015,1,0,'主力进出'),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.107,1,0,'散户进出'),COLORCYAN;

通达信降龙七式主图指标公式

 

相关文章