在线检测未来函数

大智慧大盘指数指标公式

来源:Internet,编辑:股旁网,2013-05-15

M5:MA("DPSJYY.SP",5);
M10:MA("DPSJYY.SP",10);
M20:MA("DPSJYY.SP",20);
M55:MA("DPSJYY.SP",55),LINETHICK2;
M120:MA("DPSJYY.SP",125),LINETHICK2;
M250:MA("DPSJYY.SP",250),COLORCYAN,LINETHICK2;
STICKLINE("DPSJYY.SP">"DPSJYY.KP" OR "DPSJYY.SP"="DPSJYY.KP" AND "DPSJYY.SP">REF("DPSJYY.SP",1),"DPSJYY.ZD","DPSJYY.ZG",0.5,0),LINETHICK5,color010000;
STICKLINE("DPSJYY.SP">"DPSJYY.KP" OR "DPSJYY.SP"="DPSJYY.KP" AND "DPSJYY.SP">REF("DPSJYY.SP",1),"DPSJYY.KP","DPSJYY.SP",7,0),LINETHICK5,color010000;
STICKLINE("DPSJYY.SP"<"DPSJYY.KP" OR "DPSJYY.SP"="DPSJYY.KP" AND "DPSJYY.SP"<=REF("DPSJYY.SP",1),"DPSJYY.ZD","DPSJYY.ZG",0.5,0),LINETHICK5,color010000;
STICKLINE("DPSJYY.SP"<"DPSJYY.KP" OR "DPSJYY.SP"="DPSJYY.KP" AND "DPSJYY.SP"<=REF("DPSJYY.SP",1),"DPSJYY.KP","DPSJYY.SP",7,0),LINETHICK5,color010000;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",7,0),color0022CC;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",6,0),color0033DD;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",5,0),color0044EE;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",4,0),color0055FF;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",3,0),color0066FF;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",2,0),color0077FF;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",1,0),color0088FF;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.SP","DPSJYY.ZG",0,0),color0088FF;
STICKLINE("DPSJYY.SP">="DPSJYY.KP","DPSJYY.KP","DPSJYY.ZD",0,0),color0088FF;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",7,0),color00AA00;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",6,0),color00BB11;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",5,0),color00CC22;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",4,0),color00DD22;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",3,0),color00EE33;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",2,0),color00FF33;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.SP","DPSJYY.KP",1,0),color00FF66;
STICKLINE("DPSJYY.SP"<="DPSJYY.KP","DPSJYY.ZG","DPSJYY.ZD",0,0),color00FF66;
DRAWGBKLAST(c>1,STRIP(RGB(15,80,225),RGB(0,0,0),1));
ZG:if((STRTONUM(STKLABEL)>2000 and STRTONUM(STKLABEL)<2999 OR STRTONUM(STKLABEL)=399005),"399005$HIGH",IF((STRTONUM(STKLABEL)>300000 and STRTONUM(STKLABEL)<300500 OR STRTONUM(STKLABEL)=399006),"399006$HIGH",IF((INBLOCK('沪深300')=1 ),"399300$HIGH",INDEXH)));
ZD:if((STRTONUM(STKLABEL)>2000 and STRTONUM(STKLABEL)<2999 OR STRTONUM(STKLABEL)=399005),"399005$LOW",IF((STRTONUM(STKLABEL)>300000 and STRTONUM(STKLABEL)<300500 OR STRTONUM(STKLABEL)=399006),"399006$LOW",IF((INBLOCK('沪深300')=1 ),"399300$LOW",INDEXl)));
SP:if((STRTONUM(STKLABEL)>2000 and STRTONUM(STKLABEL)<2999 OR STRTONUM(STKLABEL)=399005),"399005$CLOSE",IF((STRTONUM(STKLABEL)>300000 and STRTONUM(STKLABEL)<300500 OR STRTONUM(STKLABEL)=399006),"399006$CLOSE",IF((INBLOCK('沪深300')=1 ),"399300$CLOSE",INDEXc)));
kP:if((STRTONUM(STKLABEL)>2000 and STRTONUM(STKLABEL)<2999 OR STRTONUM(STKLABEL)=399005),"399005$open",IF((STRTONUM(STKLABEL)>300000 and STRTONUM(STKLABEL)<300500 OR STRTONUM(STKLABEL)=399006),"399006$open",IF((INBLOCK('沪深300')=1 ),"399300$open",INDEXo)));

大智慧大盘指数指标公式

 

相关文章