在线检测未来函数

通达信多周期MACD指标公式

来源:Internet,编辑:股旁网,2013-06-13

此指标对回调介入法判断变盘的临界点有一定的帮助。 此指标是周MACD、日MACD、60分钟、30分钟MACD同在一个副图中,减少的盘中撤换的麻烦。

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2;
DEA:EMA(DIFF,9),LINETHICK2;
MACD:(DIFF-DEA)*2, COLORSTICK;
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');
DRAWBAND(DIFF,RGB(224,224,224),DEA,RGB(255,255,96));{60F}
DIF55:=(EMA(CLOSE,30)-EMA(CLOSE,100));
DEA55:=(EMA(DIF55,45));
DRAWBAND(DEA55,RGB(0,150,50),DIF55,RGB(155,50,50));
F60:EMA(CLOSE,12/2)-EMA(CLOSE,26/2),COLORCYAN;
A60:EMA(F60,9/2);
DRAWBAND(F60,RGB(0,224,224),A60,RGB(255,96,96));{30F}
F30:(EMA(CLOSE,12/4)-EMA(CLOSE,26/4)),COLORGREEN;
A30:(EMA(F30,9/4));
DRAWBAND(F30,RGB(0,224,0),A30,RGB(255,96,255));{15F};
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');

通达信多周期MACD指标公式

 

相关文章