在线检测未来函数

通达信MACD短线指标公式

来源:Internet,编辑:股旁网,2013-07-13

VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
SJ: (VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
SD: MA(SJ,2);
SK: MA(SJ,1);
VAR3:=CROSS(SK,SD) AND SK<0;
VAR4:=CROSS(SK,0);
VAR5:=CROSS(SK,SD) AND SK>0;
强弱分界: 0;
VAR6:SJ,COLORRED;
VAR7:SD,COLORRED;
关注:IF(VAR6>REF(VAR6,1),VAR6,DRAWNULL),COLORRED;
持股:IF(VAR7>REF(VAR7,1),VAR7,DRAWNULL),COLORRED;
观望:IF(VAR6<REF(VAR6,1),VAR6,DRAWNULL),COLORGREEN;
持币:IF(VAR7<REF(VAR7,1),VAR7,DRAWNULL),COLORGREEN;
MC:=MA(C,5);
VC:=C-MC;{V:=DC}
MVC:=MA(VC,3);
AC:=VC-MVC;{A:=D(V)=D(DC)}
LB:=MA(V,15)/MA(V,150);
KLIFX:=AC*LB;
STICKLINE(KLIFX>=0,0,KLIFX,3,1),COLORYELLOW;
STICKLINE(KLIFX<0,0,KLIFX,3,1),COLORWHITE;
SHORT:=5;
LONG:=55;
MID:=10;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK2;
DEA:EMA(DIF,MID),COLORRED,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK;

通达信MACD短线指标公式

 

相关文章