在线检测未来函数

通达信决战股市主图指标公式

来源:Internet,编辑:股旁网,2013-07-18

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,7,0),CoLor0000FF;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,4,0),CoLor7070FF;
STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,2,0),CoLor00FFFF;
STICKLINE((CLOSE>=OPEN),HIGH,LOW,0,0),CoLor00FFFF;
STICKLINE((CLOSE<=OPEN),CLOSE,OPEN,7,0),CoLorFF2020;
STICKLINE((CLOSE<=OPEN),CLOSE,OPEN,4,0),CoLorFF6600;
STICKLINE((CLOSE<=OPEN),CLOSE,OPEN,2,0),CoLorFFCC66;
STICKLINE((CLOSE<=OPEN),HIGH,LOW,0,0),CoLorFFCC66;
STICKLINE((CLOSE<OPEN) AND (CLOSE<REF(CLOSE,1)),CLOSE,OPEN,7,0),CoLorFF2020;
STICKLINE((CLOSE<OPEN) AND (CLOSE<REF(CLOSE,1)),CLOSE,OPEN,4,0),CoLorFF6600;
STICKLINE((CLOSE<OPEN) AND (CLOSE<REF(CLOSE,1)),CLOSE,OPEN,2,0),CoLorFFCC66;
STICKLINE((CLOSE<OPEN) AND (CLOSE<REF(CLOSE,1)),HIGH,LOW,0,0),CoLorFFCC66;
{LL:=IF((YEAR<=2008) AND (MONTH<=12),1,0); }
MA3:=MA((LOW+HIGH+CLOSE+OPEN)/(4),3);
MA5:=MA((LOW+HIGH+CLOSE+OPEN)/(4),5);
趋势线:ZIG(3,19),Linethick3,CoLor0000FF;
操盘线:(MA3+MA5)/(2),Linethick2,CoLor00FFFF;
安全线:MA((LOW+HIGH+CLOSE+OPEN)/(4),20),CoLorDCDCDC;
STICKLINE(安全线,安全线,0,0,0),CoLorDCDCDC;
牛熊分界线:(MA((LOW+HIGH+CLOSE+OPEN)/(4),120))*(0.737),CoLor00FFFF;
DRAWTEXT(牛熊分界线 AND (CLOSE>=牛熊分界线),牛熊分界线,'∧'),CoLor00FFFF;
DRAWTEXT(牛熊分界线 AND (CLOSE<牛熊分界线),牛熊分界线,'∨'),CoLorFFFFFF;
DRAWTEXT(CROSS(操盘线,安全线),(LOW)*(0.98),'★'),CoLor00FFFF;
DRAWTEXT(CROSS(操盘线,安全线),(LOW)*(0.95),'-B买'),CoLor00FFFF;
DRAWTEXT(CROSS(安全线,操盘线),(HIGH)*(1.08),'◆'),CoLor00FF7F;
DRAWTEXT(CROSS(安全线,操盘线),(HIGH)*(1.05),'-S卖'),CoLor00FF7F;
STICKLINE(CROSS(操盘线,安全线) AND (CLOSE>OPEN),(CLOSE)*(0.995),(OPEN)*(1.005),6,0),CoLor00FFFF;
STICKLINE(CROSS(安全线,操盘线) AND (CLOSE>OPEN),(CLOSE)*(0.995),(OPEN)*(1.005),6,0),CoLor00FF7F;
STICKLINE(CROSS(操盘线,安全线) AND (CLOSE=OPEN),CLOSE,OPEN,6,0),CoLor00FFFF;
STICKLINE(CROSS(安全线,操盘线) AND (CLOSE=OPEN),CLOSE,OPEN,6,0),CoLor00FF7F;
STICKLINE(CROSS(操盘线,安全线) AND (CLOSE<OPEN),(CLOSE)*(1.005),(OPEN)*(0.995),6,0),CoLor00FFFF;
STICKLINE(CROSS(安全线,操盘线) AND (CLOSE<OPEN),(CLOSE)*(1.005),(OPEN)*(0.995),6,0),CoLor00FF7F;
DRAWTEXT((牛熊分界线>REF(LOW,1)) AND (CLOSE>牛熊分界线) AND (CLOSE>(REF(CLOSE,1))*(1.035)),(HIGH)*(1.05),'强势跟进'),CoLor00FFFF;
DRAWTEXT((牛熊分界线<REF(CLOSE,1)) AND (CLOSE<牛熊分界线) AND (CLOSE<REF(CLOSE,1)),(HIGH)*(1.05),'弱势卖出'),CoLor00FFFF;
箱顶:=HHV(MA((LOW+HIGH+CLOSE+OPEN)/(4),5),58);
箱底:=LLV(MA((LOW+HIGH+CLOSE+OPEN)/(4),6),58);
VAR7:=((INDEXC)*(2)+INDEXH+INDEXL)/(4);
VAR8:=EMA(VAR7,13)-EMA(VAR7,34);
VAR9:=EMA(VAR8,5);
VARA:=VAR8-VAR9+箱底;
DRAWTEXT(CROSS(MA3,箱底) AND (CLOSE>安全线),LOW,'试买'),CoLorFFFFFF;
DRAWTEXT(CROSS(MA3,MA(CLOSE,34)),(LOW)*(0.98),'买进'),CoLorFFFFFF;
DRAWTEXT(CROSS(箱顶,MA3) AND (CLOSE<箱顶),(LOW)*(0.98),'卖出'),CoLorFFFFFF;
DRAWTEXT((REF(VARA,2)<REF(VARA,1)) AND (REF(VARA,1)>VARA) AND (VARA>箱顶) AND (CLOSE>箱顶),(HIGH)*(1.005),'短卖'),CoLorFFFFFF;
DRAWTEXT(CROSS(MA5,MA(CLOSE,30)) AND (CLOSE<(EMA(CLOSE,240))*(0.75)),LOW-(LOW)*(0.05),'←中底买 '),CoLorFFFFFF;

通达信决战股市主图指标公式

 

相关文章