在线检测未来函数

通达信枪神VOL指标公式

来源:Internet,编辑:股旁网,2013-08-05

N:=18;
P:=2;
M1:= MA(VOL,8);
M2:= MA(VOL,35);
M3:= MA(VOL,89);
M4:= MA(VOL,135);
VVOL:= IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL * 240/FROMOPEN,DRAWNULL);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME: VOL,VOLSTICK;
倍量: VOL>=REF(V,1) * 1.90 AND C>REF(C,1),NODRAW,COLORYELLOW;
低量: VOL<REF(LLV(VOL,13),1),NODRAW,COLORGREEN;
AA:= SUMBARS(VOL,CAPITAL);
地量:= IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA) * 30/100 AND VOL>0);
STICKLINE(地量,VOL,0,1.5,0),COLORYELLOW;
平量: (ABS(VOL - HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.055) OR (ABS(VOL - REF(VOL,1))/REF(VOL,1)<=0.055),NODRAW,COLORWHITE;
倍缩: VOL<=REF(V,1) * 0.5,NODRAW,COLORBLUE;
梯量: COUNT(V>REF(V,1),3)=3 AND COUNT(C>O,3)=3,NODRAW,COLOR824173;
缩量涨: COUNT(C>REF(C,1),2)=2 AND COUNT(V<REF(V,1),2)=2,NODRAW,COLORBLUE;
STICKLINE(倍量,0,V,1,0),COLORYELLOW;
STICKLINE(平量,0,V,1,0),COLORWHITE;
STICKLINE(倍缩 AND VOL<M2,0,V,1,0),COLORBLUE;
STICKLINE(梯量,0,V,1,0),COLOR824173;
STICKLINE(缩量涨,0,V,1,0),COLORBLUE;
RSV:= (C - LLV(L,9))/(HHV(H,9) - LLV(L,9)) * 100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3 * K - 2 * D;
X:= LLV(J,2)=LLV(J,8);
Y:= IF(CROSS(J,REF(J + 0.01,1)) AND X AND J<20,30,0);
主力:= EMA((CLOSE - MA(CLOSE,3))/MA(CLOSE,3),2);
散户:= EMA((CLOSE - MA(CLOSE,20))/MA(CLOSE,20),7);
短:= CROSS(J,REF(J + 0.01,1)) AND X AND J<20,COLORRED;
底:= CROSS(主力,散户) AND 主力<0 AND 散户<0;
LC:= REF(CLOSE,1);
RSI5:= SMA(MAX(CLOSE - LC,0),5,1)/SMA(ABS(CLOSE - LC),5,1) * 100;
TR1:= SUM(MAX(MAX(HIGH - LOW,ABS(HIGH - REF(CLOSE,1))),ABS(LOW - REF(CLOSE,1))),10);
HD:= HIGH - REF(HIGH,1);
LD:= REF(LOW,1) - LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),10);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),10);
PDI:= DMP * 100/TR1;
MDI:= DMM * 100/TR1;
ADX:= MA(ABS(MDI - PDI)/(MDI + PDI) * 100,5);
AV:= RSI5 + ADX;
DXR:= (ADX + REF(ADX,5))/2 + RSI5;
WR10:= 100 * (HHV(HIGH,10) - CLOSE)/(HHV(HIGH,10) - LLV(LOW,10));
NEWVOL:= RSI5 - WR10;
ZJ买入:= AV + NEWVOL;
短线1: (CROSS(ZJ买入,0) OR (ZJ买入<5)) AND (短 OR 底),NODRAW,COLOR1020FF,COLORRED;
短线3:= CROSS(ZJ买入,0),COLORRED;
STICKLINE(短线1,0,VOL,3,0),COLOR1020CC;
STICKLINE(短线1,0,VOL * 0.5,2.5,0),COLOR1020DD;
STICKLINE(短线1,0,VOL * 0.5,2,0),COLOR1020EE;
STICKLINE(短线1,0,VOL * 0.5,1,0),COLOR1020FF;
STICKLINE(短线3,0,VOL,3,0),COLOR1020CC;
STICKLINE(短线3,0,VOL * 0.5,2.5,0),COLOR1020DD;
STICKLINE(短线3,0,VOL * 0.5,2,0),COLOR1020EE;
STICKLINE(短线3,0,VOL * 0.5,1,0),COLOR1020FF;
短线2: ZJ买入<5 AND (短 OR 底),NODRAW,COLORGREEN;
STICKLINE(短线2,0,VOL * 0.3,2,0),COLORCYAN;
RRSV:= (CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)) * 50;
KK:= SMA(RRSV,3,1);
DD:= SMA(K,3,1);
JJ:= 3 * KK - 2 * DD;
XX:= LLV(JJ,2)=LLV(JJ,8);
买入时机:= CROSS(JJ,3);
STICKLINE(短线1,0,VOL,3,0),COLOR1020CC;
STICKLINE(短线1,0,VOL * 0.5,2.5,0),COLOR1020DD;
STICKLINE(短线1,0,VOL * 0.5,2,0),COLOR1020EE;
STICKLINE(短线1,0,VOL * 0.5,1,0),COLOR1020FF;
STICKLINE(买入时机,0,VOL,2,0),COLOR999900;
STICKLINE(买入时机,0,VOL,2,0),COLORDDDD00;
STICKLINE(买入时机,0,VOL,1,0),COLORCYAN;
M8: MA(VOL,8);
M35: MA(VOL,35);
M89: MA(VOL,89);
M135: MA(VOL,135);
ZT:= REF(C,1) * 1.1 - C<0.01;
ZTJJ: BARSLAST(ZT);
涨缩:= VOL<MA(VOL,35) AND ZTJJ<19;
IF(涨缩=1,0,DRAWNULL),CIRCLEDOT,COLORRED;
STICKLINE(涨缩=1,0,VOL,0.5,0),COLORBLUE;

通达信枪神VOL指标公式

 

相关文章