在线检测未来函数

通达信狂牛启动指标公式

来源:Internet,编辑:股旁网,2013-12-03

JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
抓牛:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 ;
STICKLINE(抓牛=1,0,1,3,0),COLORRED;
DRAWTEXT(抓牛=1,1,' 抓牛'),COLORRED;
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
筹码突破:=C>TYX3 AND(C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),COLORRED;
A111:=COST(85);
A222:=COST(15);
A333:=A111-A222;
A444:=(A111+A222)/2;
单峰密集:=A333/A444*100<30,LINETHICK0;
{A5:=A3/A4*100<30;}
B1:=HHV(HIGH,250);
B2:=LLV(LOW,250);
B3:=B1-B2;
B4:=(A444-B2);
低位:=A444<(B3*04+B2),LINETHICK0;
低位单峰密集:=单峰密集 AND 低位;
B5:=C/REF(C,1)>1.04; {AND V/REF(V,1)>2;{ AND H=C;}
主力持仓%:=EMA(100*(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30)),3);
主力持仓大于75%:=主力持仓%>=75 {AND 主力持仓%<=91} AND C>0 AND CLOSE>OPEN AND C=H;
敢死吗:=主力持仓大于75% AND 低位单峰密集 AND B4 AND WINNER(C)>=0.91 AND B5,COLORGREEN,LINETHICK3;
STICKLINE(FILTER(敢死吗=1,5),0,2,2,0),COLORWHITE;
DRAWTEXT(FILTER(敢死吗=1,5)=1,2,' 敢死吗'),COLORWHITE;
机构:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/CAPITAL;
累计:=EMA(机构,60)*60,COLORMAGENTA;
均值:=EMA(累计,MIN(10,60)),COLORWHITE;
启爆点:=CROSS(累计,均值);
STICKLINE(启爆点=1,0,3,1,0),COLORMAGENTA;
DRAWTEXT(启爆点=1,3,' 启爆点'),COLORMAGENTA;
JGV:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/10000000;
DHV:=(L2_VOL(1,0) - L2_VOL(1,1))*VOL/10000000;
ZHV:=(L2_VOL(2,0) - L2_VOL(2,1))*VOL/10000000;
SHV:=(L2_VOL(3,0) - L2_VOL(3,1))*VOL/10000000;
机构资金:=EMA(JGV,60)*60/10000000,COLORMAGENTA;
游资资金:=EMA(DHV,60)*60/10000000,COLOR3399FF ;
中户资金:=EMA(ZHV,60)*60/10000000,COLORCYAN;
散户资金:=EMA(SHV,60)*60/10000000,COLORGREEN;
机构启爆:=CROSS(机构资金,散户资金);
STICKLINE(机构启爆=1,0,4,0.5,0),COLORWHITE;
DRAWTEXT(机构启爆=1,4,' 机构启爆'),COLORWHITE;

通达信狂牛启动指标公式

 

相关文章