在线检测未来函数

通达信MACD+K线+BOLL指标公式

来源:Internet,编辑:股旁网,2014-01-19

CC:=FORCAST(C,3);
OO:=FORCAST(O,3);
HH:=FORCAST(H,3);
LL:=FORCAST(L,3);
SHORT:=12;
LONG:=26;
M:=9;
{1.MACD}
DIFF:=EMA(CC,SHORT) - EMA(CC,LONG);
DEA:=EMA(DIFF,M);
MACD:WMA((DIFF-DEA),3)*4,COLOR00FF00,LINETHICK2;
IF(MACD>REF(MACD,1),MACD,DRAWNULL),COLOR0000FF,LINETHICK2;
{2.MACD的线}
{差可能是正,是负-----相当与DIFF}
DC:=WMA(CC,SHORT/2)-WMA(CC,LONG/2); {收盘价的DIFF}
DK:=WMA(OO,SHORT/2)-WMA(OO,LONG/2); {开盘价的DIFF}
DH:=(WMA(HH,SHORT/2)-WMA(HH,LONG/2))*1.25; {最高价的DIFF}
DL:=(WMA(LL,SHORT/2)-WMA(LL,LONG/2))*1.25; {最低价的DIFF}
{另类:收阳K线 -------收盘的DIFF>开盘的DIFF--------}
STICKLINE(DC>=DK,DH,DC,0,0),COLOR0099FF;
STICKLINE(DC>=DK,DL,DK,0,0),COLOR0099FF;
STICKLINE(DC>=DK,DC,DK,4,0),COLOR0F33AA;
STICKLINE(DC>=DK,DC,DK,3,0),COLOR0F55AA;
STICKLINE(DC>=DK,DC,DK,2,0),COLOR0F77CC;
STICKLINE(DC>=DK,DC,DK,1,0),COLOR0F99DD;
{另类:收阴K线 --------收盘的DIFF<开盘的DIFF-------}
STICKLINE(DC<DK,DH,DK,0,0),COLOR00FF99;
STICKLINE(DC<DK,DL,DC,0,0),COLOR00FF99;
STICKLINE(DC<DK,DC,DK,4,0),COLOR003300;
STICKLINE(DC<DK,DC,DK,3,0),COLOR006600;
STICKLINE(DC<DK,DC,DK,2,0),COLOR009900;
STICKLINE(DC<DK,DC,DK,1,0),COLOR00BB00;
{3.MACD的BOLL}
MID:MA(DC,LONG/2),COLOR00FF00,LINETHICK1;
UPPER:MID+2*STD(DC,LONG/2),COLOR0068FF;
LOWER:MID-2*STD(DC,LONG/2),COLORFF9900;
IF(MID>REF(MID,1),MID,DRAWNULL),COLOR0000FF,LINETHICK1;
{卖}
TYP:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3),LINETHICK0;
AAX:=(TYP-MA(TYP,9))/MA(TYP,9)*100;
VARM:=MIN(EXIST(TYP,55),9);
AAX1:=EMA(AAX,VARM) *VARM;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:AAX3>10 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1),COLOR00FFFF,LINETHICK0;
DRAWTEXT(卖 ,MACD*0.95,'◆卖'),COLOR00FFFF,LINETHICK1;

通达信MACD+K线+BOLL指标公式

 

相关文章