在线检测未来函数

通达信马上起涨指标公式

来源:Internet,编辑:股旁网,2014-02-02

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
DRAWBAND(DIF,RGB(200,10,10),DEA,RGB(30,180,00));
MACD:(DIF-DEA)*2,COLORSTICK;
VPC:=SUM(C*V,20)/SUM(V,20) - MA(C,20);{成交量价格确认或矛盾(VPC+/-),长期VWMA减去长期SMA}
VPR:=(SUM(C*V,5)/SUM(V,5))/MA(C,5);{成交量价格比率,短期VWMA除以短期SMA}
VM:=MA(V,5)/MA(V,20);{成交量乘数,短期平均成交量除以长期平均成交量}
VPCI:VPC*VPR*VM*1.382,LINETHICK2,COLORMAGENTA;
VPCIMA:MA(VPCI,21),LINETHICK2,COLORGREEN;
VPMA:=MA(VPCI,90),LINETHICK1,COLORGREEN,DOTLINE;
{MA3:MA(价涨1*10,3),DOTLINE,COLORYELLOW;}
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'价格上升,VPCI上升,成交量价格确认,牛市买入信号!'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,'价格上升,VPCI下降,成交量价格矛盾,熊市卖出信号!'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.2,0,'价格下降,VPCI上升,成交量价格矛盾,牛市买入信号!');
DRAWTEXT_FIX(ISLASTBAR,0,0.3,0,'价格下降,VPCI下降,成交量价格确认,熊市卖出信号!'),COLORRED;
RSV:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
K:=SMA(RSV,8,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
CROSS(K,D)/3;

通达信马上起涨指标公式

 

相关文章