在线检测未来函数

通达信RSI突破下降趋势线选股指标公式

来源:Internet,编辑:股旁网,2014-05-04

RSI:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100,COLORWHITE;
A1:=REF(RSI,2)=HHV(RSI,2*2+1);
B1:=FILTER(A1,2);
C1:=BACKSET(B1,2+1);
D1:=FILTER(C1,2);{高}
A2:=REF(RSI,2)=LLV(RSI,2*2+1);
B2:=FILTER(A2,2);
C2:=BACKSET(B2,2+1);
D2:=FILTER(C2,2);{低}
H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1));
H2:=D1 AND NOT(D2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
S1:=R1>REF(R1,1); {前一高}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1); {前二高}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2);
S3:=R3>REF(R3,1); {前三高}
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2);
压一:=DRAWLINE(S2,RSI,S1,RSI,1),COLOR00B5B9,COLORRED; {压力1}
压二:=DRAWLINE(S3,RSI,S2,RSI,1),COLOR009AFF; {压力2}
XG:CROSS(RSI,压一) OR CROSS(RSI,压二);

通达信RSI突破下降趋势线选股指标公式

 

相关文章