在线检测未来函数

通达信感谢天地指标公式

来源:Internet,编辑:股旁网,2014-05-13

N:=21;
杀手:100-100*(HHV(HIGH,5*N)-CLOSE)/(HHV(HIGH,5*N)-LLV(LOW,5*N)),NODRAW;
底部:IF(杀手<1,10,0),COLORGREEN,LINETHICK4;
LNA: EMA(100*(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)),3)/4,NODRAW;
DRAWICON(LNA>23.15,LNA,12);
DRAWICON(LNA<1,5,1);
DX:LNA<1,COLORYELLOW;
BIAS3:=MA((CLOSE-MA(CLOSE,24))/MA(CLOSE,24),3)*100,COLORBLACK;
BIAS2:=MA((CLOSE-MA(CLOSE,12))/MA(CLOSE,12),3)*100,COLORBLACK;
见底:IF(BIAS3<-14,10,0),LINETHICK4,COLORYELLOW;
短底:IF(BIAS2<-7,10,0),COLORYELLOW,LINETHICK2;
见顶:IF(BIAS3>14,10,0),LINETHICK4,COLORRED;
短顶:IF(BIAS2>7,10,0),COLORRED;
AI:=AMOUNT/VOL/100;
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
DSY:=100*VOL/CAPITAL;
抄底:IF((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,100, 0),COLOR00FF00;
A:=1.1*C;
B:=0.9*C;
B1:=100*(WINNER(A)-WINNER(B)),NODRAW;
CM :100-B1,NODRAW;
C11:=MA(C,13)<REF(MA(C,13),1),NODRAW;
备卖:IF(CROSS(CM,90)AND C1,90,0);
CMQ:STICKLINE(CM>65 AND C11,CM-50,0,6,0),NODRAW;
VAR1AA:=1/WINNER(CLOSE),NODRAW;
VAR2AA:=MA(CLOSE,13),NODRAW;
VAR3:=100-ABS((CLOSE-VAR2AA)/VAR2AA*100),NODRAW;
VAR4:=LLV(LOW,75),NODRAW;
VAR5:=HHV(HIGH,75),NODRAW;
VAR6:=(VAR5-VAR4)/100,NODRAW;
VAR7:=SMA((CLOSE-VAR4)/VAR6,20,1),NODRAW;
VAR8:=SMA((OPEN-VAR4)/VAR6,20,1),NODRAW;
VAR9:=3*VAR7-2*SMA(VAR7,15,1),NODRAW;
VARA:=3*VAR8-2*SMA(VAR8,15,1),NODRAW;
VARB:=100-VARA,NODRAW;
VARC:=IF(900101<DATE AND DATE<99991230,1,0),NODRAW;
SL: (100-VAR9)*VARC, , {000B0001},NODRAW;
SH: MA(WINNER(CLOSE*0.95)*100,3)*VARC, , COLORYELLOW,NODRAW;
XZ: (100-IF(VAR1AA>5,IF(VAR1AA<100,VAR1AA,VAR3-10),0))*VARC, , COLORGREEN,NODRAW;
VARD:=SH>VAR3,NODRAW;
VARE:=REF(LOW,1)*0.9,NODRAW;
VARF:=LOW*0.9,NODRAW;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL,NODRAW;
VAR11:=EMA(VAR10,30),NODRAW;
VAR12:=CLOSE-REF(CLOSE,1),NODRAW;
VAR13:=MAX(VAR12,0),NODRAW;
VAR14:=ABS(VAR12),NODRAW;
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100,NODRAW;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100,NODRAW;
VAR17:=BARSCOUNT(CLOSE),NODRAW;
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100,NODRAW;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100,NODRAW;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,NODRAW;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1),NODRAW;
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100,NODRAW;
VAR1D:=SMA(VAR1C,4,1),NODRAW;
VAR1E:=SMA(VAR1D,3,1),NODRAW;
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100,NODRAW;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50,NODRAW;
VAR21:=(HIGH+LOW+CLOSE)/3,NODRAW;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14)),NODRAW;
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70)),NODRAW;
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0),NODRAW;
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24),NODRAW;
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,NODRAW;
VAR27:=REVERSE(VAR26),NODRAW;
VAR28:=SMA(VAR26,3,1),NODRAW;
SHA: SMA(VAR28,3,1)*VARC, ,,NODRAW;
XZA: SMA(SHA,3,1)*VARC, , COLORYELLOW,NODRAW;
DY: IF(CROSS(SHA,XZA) AND SHA<30,XZA,0)*VARC, , COLORRED,NODRAW;
TT: IF(CROSS(XZA,SHA) AND XZA>75,XZA,100)*VARC, , COLORGREEN,NODRAW;
DRAWTEXT(CROSS(SHA,XZA) AND SHA<30,XZA,'逢低吸呐 !'), ,COLORWHITE,NODRAW;
DRAWTEXT(CROSS(XZA,SHA) AND XZA>75,XZA,'逢高减磅!'), , COLORGREEN,NODRAW;
小心断裂: (IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50)*VARC, , {00050006},NODRAW;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,35,'备钱'), , COLORYELLOW;
STICKLINE(VAR20,0,80,1,0), , COLORRED;
顶: 97,COLORBLUE,DOTLINE;
波段高抛注意: 80,COLORMAGENTA,DOTLINE;
趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORRED,LINETHICK3;
波段低吸: 20,COLORRED,DOTLINE;
底:8,COLORWHITE,DOTLINE;
强弱分界: 50,COLORGRAY,DOTLINE;
趋势1:(EMA(((CLOSE-LLV(LOW,36))/(HHV(HIGH,30)-LLV(LOW,36)))*(4),4))*(25),COLORGREEN,NODRAW;
上限:87.5,COLOR00FF00,,NODRAW;
减1:IF(FILTER(CROSS(趋势1,86)AND C>=MA(C,60),10),72,87.5),COLORWHITE;
DRAWTEXT(FILTER(CROSS(趋势1,86)AND C>=MA(C,60),10), 68,'S'),COLORYELLOW;
减2:IF(FILTER(CROSS(趋势1,92),10),67,87.10),COLORWHITE;
DRAWTEXT(FILTER(CROSS(趋势1,92),10),65,'S'),COLORWHITE;
减3:IF(FILTER(CROSS(95,趋势1),3),62,87.5),COLORRED;
DRAWTEXT(FILTER(CROSS(95,趋势1),3),60,'逃顶'),COLORWHITE;
DRAWICON(FILTER(CROSS(MA(CLOSE,26) + 2*STD(CLOSE,26),C),4),趋势1*1.1,2);
BIAS11:=(C-MA(C,6))/MA(C,6)*100;
BIAS21:=(C-MA(C,12))/MA(C,12)*100;
BIAS31:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS11+2*BIAS21+3*BIAS31)/6;
乖离:=MA(BIAS,3);
极边底:(CROSS(BIAS,乖离) AND 乖离<-9),COLORRED;
STICKLINE(CROSS(BIAS,乖离) AND 乖离<-9,10,0,5,0),COLORRED;
底啊:IF((MA(C,5)-C)/C>0.03 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.03,23,0),LINETHICK2,COLORFF00FF;
DRAWICON(底啊=23,23,1),LINETHICK2,COLORFFFFFF;
当日换手:=V/CAPITAL*100;
获利盘:=WINNER(C)*100;
FC:=(WINNER(C*1.1)-WINNER(C*0.9))/WINNER(HHV(H,0));
相对换手:=V/(CAPITAL*FC)*100;
观望者众:=相对换手<=6;
交投活跃:=相对换手>6 AND 相对换手<14;
成交异常:=相对换手>=14;
底1:=IF((MA(C,5)-C)/C>0.03 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.03,23,0) AND 成交异常;
DRAWICON(底1,23,17),LINETHICK2,COLORWHITE;

通达信感谢天地指标公式

 

相关文章