在线检测未来函数

通达信财富平台主图指标公式

来源:Internet,编辑:股旁网,2014-08-25

布林:=HHV(HHV(L,14),60);
阻力区:=EMA(EMA(布林,16)-2*STD(布林,16),3);
阻力区1:=EMA(EMA(布林,14)+2*STD(布林,14),18);
DRAWBAND(阻力区,RGB(241,241,247),阻力区1,RGB(241,241,247));
STICKLINE(C>=O,C,O,3,0),COLOR0000AA;
STICKLINE(C>=O,C,O,2.5,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000CC ;
STICKLINE(C>=O,C,O,1,0),COLOR0000EE;
STICKLINE(C>=O,H,L,0,0),COLOR0000FF;
STICKLINE(C<=O,C,O,3,0),COLOR7B7B00;
STICKLINE(C<=O,C,O,2.5,0),COLOR909000;
STICKLINE(C<=O,C,O,1.5,0),COLORA8A800;
STICKLINE(C<=O,C,O,1,0),COLORCECE00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
B1:='-------';
DRAWTEXT(VOL=HHV(VOL,21),C ,B1),COLORRED;
VARM2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VARM3:=SMA(SMA(VARM2,9,4),9,4)/7.777777;
VARM4:=EMA(VARM3,5);
VARM5:=3*VARM3-2*VARM4;
AAM:=CROSS(VARM5,VARM3) AND VARM3<1.7777777 AND C>O;
VARM6:=(2*CLOSE+HIGH+LOW)/4;
VARM7:=LLV(LOW,13);
VARM8:=HHV(HIGH,13);
VARM9:=EMA((VARM6-VARM7)/(VARM8-VARM7)*100,13);
VARMA:=EMA(0.667*REF(VARM9,1)+0.333*VARM9,2);
DRAWTEXT(AAM,L,'区域底部'),COLORMAGENTA;
中轨:MA(CLOSE,24),COLORYELLOW,LINETHICK2;
上轨:中轨 + STD(CLOSE,24),COLORRED,LINETHICK2;
下轨:中轨 - STD(CLOSE,24),COLOREE11EE,LINETHICK2;
阻力差:阻力区1-阻力区,NODRAW;
缩小:BARSLASTCOUNT(阻力差<REF(阻力差,1)),NODRAW;
放大:BARSLASTCOUNT(阻力差>REF(阻力差,1)),NODRAW;
A:=HHV(H,30);
回落比:C/A*100,NODRAW;
DRAWICON(CROSS(回落比,95) AND C>REF(C,1),下轨,1);
AAA0:=(3*C+H+L+O)/6;
短趋:=(8*AAA0+7*REF(AAA0,1)+6*REF(AAA0,2)+5*REF(AAA0,3)+4*REF(AAA0,4)+3*REF(AAA0,5)+2*REF(AAA0,6)+REF(AAA0,8))/36;
中趋:=(LLV(短趋,2)+LLV(短趋,4)+LLV(短趋,6))/3;
TTJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>短趋;
立桩量:=FILTER(TTJ1,5);
TTJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TTJ2=1;
TTJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TTJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWICON(条件成立,L*0.91,1);
DRAWTEXT(条件成立,L*0.91,'立桩'),COLORFF26FF;
OK:=EMA(OPEN,60);
CG:=EMA(CLOSE,60);
PDU:=IF(OK>REF(OK,1) AND CG>REF(CG,1),1,0);
PDD:=IF(OK<REF(OK,1) AND CG<REF(CG,1),1,0);
PDM:=IF(PDU=0 AND PDU=0,1,0);
Z1:=MA(CLOSE,13);
ZX:=REF(Z1,13/2+1);
LIFE:=(EMA(CLOSE,60)+EMA(CLOSE,90))/2;
VAR1:=(2*CLOSE+HIGH+LOW)/4;
SNOOK:=EMA(VAR1,99)*0.91;
A1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
MA5:=BARSLAST(A1>3);
MA20:=IF(MA5>0,1,0);
BY20:=MA(CLOSE,5);
BY21:=MA(CLOSE,20);
BY22:=IF(BY20>BY21,BY21,BY20);
招财猫:=BY21,COLORGREEN,LINETHICK1;
鼠变异:=BY22,COLORBLUE,LINETHICK2;
TT:=240/FROMOPEN;
比:=TT;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
AAA:=CONST(HHV(H,90));
BBB:=CONST(LLV(L,100));
T1:=CONST(CLOSE>ZX AND CLOSE>=LIFE);
T2:=CONST(CLOSE>ZX AND CLOSE>SNOOK AND CLOSE<LIFE);
T3:=CONST(CLOSE>ZX AND CLOSE<=SNOOK);
T4:=CONST(CLOSE<=ZX);
T5:=CONST(鼠变异>REF(鼠变异,1) AND 鼠变异>BY21 AND 鼠变异!=(鼠变异,BY21));
T6:=CONST(鼠变异>REF(鼠变异,1) AND 鼠变异=BY21 AND PDU!=(PDU,1)) ;
T7:=CONST(鼠变异>REF(鼠变异,1) AND 鼠变异=BY21 AND PDU=1);
T8:=CONST(CLOSE>ZX AND MA20=0);
TS1:=IF(T1=1,0+0.04,0);
TS2:=IF(T2=1,TS1+0.04,TS1);
TS3:=IF(T3=1,TS2+0.04,TS2);
TS4:=IF(T4=1,TS3+0.04,TS3);
TS5:=IF(T5=1,TS4+0.04,TS4);
TS6:=IF(T6=1,TS5+0.04,TS5);
TS7:=IF(T7=1,TS6+0.04,TS6);
TS8:=IF(T8=1,TS7+0.04,TS7);
DRAWTEXT(T1=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS1),'老鼠出洞了,逮住它!'),COLORFF00FF ;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS2),'老鼠玩猫猫,守着它!'),COLORFFFF00 ;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS3),'老鼠露尾巴,动作快!'),COLOR00FFFF ;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS4),'老鼠没有了,打个盹!'),COLORFFFF00 ;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS5),'发现鼠迹!'),COLORFF00FF;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS6),'瞬间鼠影!'),COLORFFFF00;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS7),'恶鼠难遁!'),COLORRED;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS8),'老鼠去哪里,思考哦!'),COLORFFFF00 ;

通达信财富平台主图指标公式

 

相关文章