在线检测未来函数

通达信涨停类别指标公式

来源:Internet,编辑:股旁网,2014-08-27

说明: 涨停时所属涨停类别越多,第二天继续涨停的机率越大。是追涨的好帮手。

STICKLINE(CLOSE,0,100,4,1),COLOR000040;
STICKLINE(CLOSE,0,80,4,1),COLOR000040;
STICKLINE(CLOSE,0,60,4,1),COLOR000040;
STICKLINE(CLOSE,0,40,4,1),COLOR000040;
STICKLINE(CLOSE,0,20,4,1),COLOR000040;
ZT:=(C-REF(C,1))/REF(C,1)*100>9.5,COLORWHITE,NODRAW;
个线:=EMA(EMA(CLOSE,30),9),NODRAW;
大线:=EMA(EMA(INDEXC,45),9),NODRAW;
个股1:=CLOSE/个线*100,NODRAW;
大盘1:=INDEXC/大线*100,NODRAW;
GGQD:=(个股1-大盘1),NODRAW;
N1:=REF(BARSLAST((C-REF(C,1))/REF(C,1)*100>9.6 AND C=H),1)+1,NODRAW;
回光返照:=IF(COUNT(CROSS(MA(C,15),MA(C,5)),N1)=0 AND HHV(GGQD,20)>23 AND MA(C,5)>MA(C,30) AND GGQD<HHV(GGQD,30)
AND GGQD>5 AND (C-REF(C,1))/REF(C,1)*100>9.6 AND C=H,-9,0),COLORBLUE,NODRAW;
BIAS1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,NODRAW;
BIAS2 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,NODRAW;
BIA:=(BIAS1-BIAS2),NODRAW;
BIS:=LLV(BIAS1,3),NODRAW;
MA5:=MA(C,5),NODRAW;
MA10:=MA(C,10),NODRAW;
MA20:=MA(C,20) ,NODRAW;
MA30:=MA(C,30),NODRAW;
MA60:=MA(C,34),NODRAW;
F1:=(MA5-MA10)/MA10*100,NODRAW;
F2:=(MA10-MA20)/MA10*100,NODRAW;
F3:=(MA20-MA60)/MA10*100,NODRAW;
TY:=C,NODRAW;
A1:=REF(TY,20)=HHV(TY,2*20+1);B1:=FILTER(A1,20);C1:=BACKSET(B1,20+1);HD:=FILTER(C1,20),NODRAW;
A:=REF(H,BARSLAST(HD)),NODRAW;
LC := REF(CLOSE,1),NODRAW;
RSI1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100,NODRAW;
突破涨停:=IF(CROSS(C,A) AND ZT>0,-4,0),COLORYELLOW;
拉升涨停:=IF(F1>1 AND F2>3 AND F3>0 AND ZT>0,6,0),COLORRED,NODRAW;
逼空涨停A:=IF(ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80,4,0),COLORCYAN,NODRAW;
逼空涨停B:=IF(GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80 AND REF(GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80,1)=0,4,0),COLORLIRED;
超跌涨停:=IF(ZT>0 AND BIS<0 AND BIA>5 AND MA(C,5)<MA(C,60),-2,0),COLORGREEN,NODRAW;
STICKLINE(突破涨停,84,97,3,0),COLORFF0080;
DRAWTEXT(ISLASTBAR=1,90,' 突破涨停'),COLOR0080FF;
STICKLINE(拉升涨停,64,77,3,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,70,' 拉升涨停'),COLOR00FFFF;
STICKLINE(逼空涨停A,44,57,3,0),COLOR0000FF;
DRAWTEXT(ISLASTBAR=1,50,' 逼空涨停'),COLORFFFFFF;
STICKLINE(逼空涨停B,24,37,3,0),COLOR00FFFF;
DRAWTEXT(ISLASTBAR=1,30,' 逼空涨停'),COLORFF00FF;
STICKLINE(超跌涨停,4,17,3,0),COLOR0080FF;
DRAWTEXT(ISLASTBAR=1,10,' 超跌涨停'),COLORFF0080;

通达信涨停类别指标公式

 

相关文章