在线检测未来函数

大智慧新龙凤吉祥指标公式

来源:Internet,编辑:股旁网,2014-09-25

VAR2:=((CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24)))* CLOSE ;
能量: SMA(VAR2,5,1),COLORRED,LINETHICK0,PRECIS2;
FILLRGN(0,能量,能量>REF(能量,1),RGB(50,0,0)),PRECIS0,LAYER5;
FILLRGN(0,能量,能量<REF(能量,1),RGB(50,55,0)),PRECIS0,LAYER5;
RSV:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * 1.2 * CLOSE ;
K:=SMA(RSV,13,1);
龙凤吉祥:=SMA(K,3,1);
我心依旧:=3 * K - 2 * 龙凤吉祥;
龙凤吉祥1:=EMA(龙凤吉祥,2);
龙凤吉祥2:=EMA(龙凤吉祥,5);
龙凤吉祥3:=EMA(龙凤吉祥,8);
STICKLINE(龙凤吉祥2 >= 龙凤吉祥3,龙凤吉祥1,龙凤吉祥3,6,0),colorred; {红}
STICKLINE(龙凤吉祥2 >= 龙凤吉祥3,龙凤吉祥1,龙凤吉祥3,0,0),colorFFFFff; {红中白}
STICKLINE(龙凤吉祥2 <= 龙凤吉祥3,龙凤吉祥1,龙凤吉祥3,6,0),color005500; {绿}
T1:=龙凤吉祥2 >= 龙凤吉祥3 AND 龙凤吉祥 < REF(龙凤吉祥,1);
T2:=龙凤吉祥2 < 龙凤吉祥3 AND 龙凤吉祥 > REF(龙凤吉祥,1);
STICKLINE(T2,龙凤吉祥1*0.97,龙凤吉祥3*1.03,10,0),COLOR0099ff;{黄}
STICKLINE(T2,龙凤吉祥1*0.97,龙凤吉祥3*1.03,6,0),color338FDD;
STICKLINE(T2,龙凤吉祥1*0.97,龙凤吉祥3*1.03,3,0),color33FFDD; {粉红加黄}
【龙】:我心依旧,LINETHICK2,colorffaa00,PRECIS2;
【凤】:龙凤吉祥,LINETHICK2,colorred,PRECIS2;
【龙】1:=EMA(【龙】,2);
【龙】2:=EMA(【龙】,5);
【龙】3:=EMA(【龙】,8);
STICKLINE(【龙】2 >= 【龙】3,【龙】1,【龙】3,6,0),colorMAGENTA;{粉红}
STICKLINE(【龙】2 >= 【龙】3,【龙】1,【龙】3,0,0),colorffaa00; {粉红中蓝}
STICKLINE(【龙】2 <= 【龙】3,【龙】1,【龙】3,6,0),colorFF7710; {蓝}
T1A:=【龙】2 >= 【龙】3 AND 【龙】 < REF(【龙】,1);
T2A:=【龙】2 < 【龙】3 AND 【龙】 > REF(【龙】,1);
STICKLINE(T1,龙凤吉祥1,龙凤吉祥3,8,0),colorDDDDFD;{白}
STICKLINE(T1A,【龙】1,【龙】3,6,0),color10B210;
STICKLINE(T1A,【龙】1,【龙】3,4,0),color10C210;
STICKLINE(T1A,【龙】1,【龙】3,1.1,0),color10D210;{绿}
{以下为新加}
QY1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
QY2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
QY3:=QY1<REF(QY2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
山水敢买:(QY3 AND COUNT(QY3,30)=1),color888888,PRECIS0;
DRAWTEXT(QY3 AND COUNT(QY3,30)=1,L,'山水敢买'),colorred,PRECIS0;
操作线:=EMA(C,5);
A:=REF(操作线,1);
{买入}
STICKLINE(操作线>=A,-1.5,-1,7,1),COLOR5454FF;
STICKLINE(操作线>=A,-1.5,-1,3,0),COLORFF00FF; {粉持股}
STICKLINE(CROSS(操作线,A),-1.5,-1,7,0),COLORRED; {红买}
{卖出}
stickline(操作线<A and close>open ,-1.5,-1,7,0),COLORCCCCCC;
stickline(操作线<A and close<=open ,-1.5,-1,7,0),COLORCCCCCC; {灰空}
STICKLINE(CROSS(A,操作线),-1.5,-1,7,0),COLOR008800; {绿跌};
{量红绿灯}
Aq:=MAX(MA(VOL,30),MA(VOL,60));
Bq:=MIN(MA(VOL,30),MA(VOL,60));
绿行:VOL>Aq,COLORGREEN,LINETHICK0,PRECIS0;
红停:VOL<Bq,COLORRED,LINETHICK0,PRECIS0;
黄等:Aq>=VOL AND VOL>=Bq,COLORYELLOW,LINETHICK0,PRECIS0 ;
STICKLINE(VOL>Aq,-0.7,-0.2,7,0),COLORGREEN;
STICKLINE(VOL<Bq,-0.7,-0.2,7,1),COLORRED;
STICKLINE(Aq>=VOL AND VOL>=Bq,-0.7,-0.2,7,0),COLORYELLOW;
Vaar2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Vaar3:=SMA(Vaar2,3,1);
Vaar4:=SMA(Vaar3,9,1);
STICKLINE(VOL AND Vaar4<16,0,-1,3,0),colorblue,PRECIS0; {0--1位置深蓝柱线 买信号}
买信号:IF(VOL AND Vaar4<16,0.2,-1),COLORffaa00,PRECIS0,LINETHICK0;

大智慧新龙凤吉祥指标公式

 

相关文章