在线检测未来函数

通达信咖喱指标公式

来源:Internet,编辑:股旁网,2014-11-10

N1:=7;
N2:=27;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
短K:SMA(RSV,3,1),COLORF580F5,LINETHICK0;
短D:SMA(短K,3,1),COLORCCDD33,LINETHICK0;
RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
中K:SMA(RSV1,5,1),COLORRED,LINETHICK0;
中D:SMA(中K,10,1),COLOR33AA33,LINETHICK0;
短:=3*短K-2*短D;
中:=3*中K-2*中D;
趋势线:(短+中)/2;
底线:10,COLORWHITE;
顶线:90,COLORWHITE;
STICKLINE(短K>短D,短K,短D,6,1),COLORF580F5;
STICKLINE(短K<=短D,短K,短D,6,1),COLORCCDD33;
STICKLINE(中K>中D,中K,中D,1,0),COLORRED;
STICKLINE(中K<=中D,中K,中D,1,0),COLORGREEN;
中J:=3*中K-2*中D;
超跌:IF(中J<0,10,0),COLORGREEN;
BDDD:=LLV(中J,2)=LLV(中J,8);
重启:IF(CROSS(中J,REF(中J+0.01,1)) AND BDDD AND 中J<20,10,-10),COLORRED;
加码:IF(CROSS(中J,REF(中J+0.01,1)) AND BDDD AND BETWEEN(中J,20,60),1,0),COLORRED;
BDGD:=HHV(中J,2)=HHV(中J,8) AND 中J>80;
小心:IF(CROSS(REF(中J-0.01,1),中J) AND REF(BDGD,1),100,120),COLORYELLOW;
STICKLINE(加码,10,25,3,0),COLORYELLOW;
MM:=短K>短D AND REF(短K,1)<REF(短D,1) AND 短K<40 ;
STICKLINE(MM,-10,5,3,0),COLORRED;
DRAWICON(COUNT(MM,3) AND CROSS(趋势线,中D) AND 短D>中D,10,15),COLORRED;
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AAAA:=COUNT(MA(CLOSE,20)>MA(CLOSE,10),10)=10;
GX:=MAX(MA(CLOSE,5),MAX(MA(CLOSE,20),MA(CLOSE,10)));
DX:=MIN(MA(CLOSE,5),MIN(MA(CLOSE,20),MA(CLOSE,10)));
BBBB:=ABS(GX/DX-1)*100<=15;
MACD:=2*(DIF-DEA);
CCCC:=COUNT(MACD<0,10)=10;
DDDD:=IF(AAAA AND BBBB AND CCCC,5,0);
STICKLINE(CROSS(0.1,DDDD) AND CROSS(MACD,0),0,15,3,0),COLORWHITE;

通达信咖喱指标公式

 

相关文章