在线检测未来函数

通达信获利MACD指标公式

来源:Internet,编辑:股旁网,2014-12-04

0,LINETHICK2;
CS:=IF(CODELIKE('60') OR CODELIKE('00') OR CODELIKE('30'),COST(50),MA(C,50)),LINETHICK0;
CB:=IF(CODELIKE('30') OR CODELIKE('6') OR CODELIKE('0') ,COST(50),MA(C,50)),LINETHICK0;
S:=IF(PERIOD>5,5,12),LINETHICK0;
LL:=IF(PERIOD>5,12,26);
DI := 100*(EMA(CLOSE,S) - EMA(CLOSE,LL))/CB,LINETHICK0;
DE := EMA(DI,IF(PERIOD>5,5,9));
MAC : 2*(DI-DE), COLORSTICK,LINETHICK0;
STICKLINE((MAC < REF(MAC,1) AND (MAC > 0)),0,MAC,1,0),LINETHICK0,COLORA000A0;
STICKLINE((MAC > REF(MAC,1) AND (MAC < 0)),0,MAC,1,0),LINETHICK2,COLOR00808F,LINETHICK0;
DIFF1:DI,COLORWHITE,LINETHICK2;
DEA1:DE,COLORYELLOW,LINETHICK2;
DRAWBAND(DIFF1,RGB(200,50,55),DEA1,RGB(50,100,10));
MACD : 2*(DIFF1-DEA1), COLORSTICK;
获利MACD:DRAWICON(CROSS( DIFF1 ,DEA1), DIFF1 ,26),LINETHICK2;
DRAWTEXT(FILTER(获利MACD,8),DEA1-0.05,'↖跟庄买进'),COLORYELLOW;
STICKLINE(获利MACD,OPEN,DIFF1,2,0),COLOR0000FF,LINETHICK2;

通达信获利MACD指标公式

 

相关文章