在线检测未来函数

通达信骗线MACD指标公式

来源:Internet,编辑:股旁网,2014-12-26

SHORT:=12;
LONG:=26;
MID:=9;
RMACD:="MACD.MACD";
H3:=REF(RMACD,3);
H2:=REF(RMACD,2);
H1:=REF(RMACD,1);
H0:=RMACD;
买:H2<0 AND H3>H2 AND H2>H1 AND H0>H1;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN;
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED;
IF(DEA<REF(DEA,1),DEA,DRAWNULL),LINETHICK2,COLORGREEN;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),LINETHICK2,COLORRED;
A:STICKLINE(MACD<REF(MACD,1),0,MACD,1,0),COLORGREEN;
B:STICKLINE(MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2),0,MACD,1,0),COLORYELLOW;
绿面:10*IF (MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),LINETHICK0,COLOR00FF00,NODRAW;
红面:10*IF (MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),LINETHICK0,COLORRED,NODRAW;

通达信骗线MACD指标公式

 

相关文章