在线检测未来函数

通达信买盘卖盘控盘指标公式

来源:Internet,编辑:股旁网,2015-01-22

AB1:=VOL*CLOSE;
{A} AB2:=SUM(AB1,1)/SUM(VOL,1);
{B} AB3:=EMA(AB2,17);
{B1} AB4:=(C*2+H+L)/4*10;
{V1B} AB5:=EMA(AB4,13)-EMA(AB4,34);
{V2B} AB6:=EMA(AB5,5);
{V3B} AB7:=2*(AB5-AB6)*5.5;
{V4B} AB8:=(INDEXC*2+INDEXH+INDEXL)/4;
{V8B} AB9:=EMA(AB8,13)-EMA(AB8,34);
{V9B} AB10:=EMA(AB9,3);
{VA} AB11:=(AB9-AB10)/2;
{VB} 个股资金:=(AB2-AB3)*100/AB2;
主力资金:=AB7;
大资金:=AB11;
红点主力进场:IF(个股资金>0 AND 主力资金>0 AND 大资金>0,-10,DRAWNULL),COLORRED,CIRCLEDOT,LINETHICK1;
V1:=EMA(EMA(CLOSE,20),20);
{V1} 力度:=(V1-REF(V1,1))/REF(V1,1)*1000,COLORFF00FF,LINETHICK2;
{控盘力度} 开始控盘:IF(CROSS(力度,0),20,0),LINETHICK2,COLORYELLOW;
【庄控盘】:IF(力度>REF(力度,1) AND 力度>0,8,0),LINETHICK2,COLORRED;
白线主力减仓:IF(力度< REF(力度,1) AND 力度>0,力度,0),LINETHICK2,COLORWHITE;
绿点主力出场:IF(个股资金<=0 AND 主力资金<=0 AND 大资金<=0,-10,DRAWNULL),COLORGREEN,CIRCLEDOT,LINETHICK1;
主力动态:(个股资金+主力资金+大资金),COLORYELLOW,NODRAW;
STICKLINE(主力动态>0,0,主力动态,1,0),COLORFF00FF;
STICKLINE(主力动态<=0,0,ABS(主力动态),1,0),COLORGREEN;
比例:(主力动态-REF(主力动态,1))/REF(主力动态,1),NODRAW;
底部:0,COLORFFCC66,LINETHICK2;
虚:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚,0,-1,-1),COLOR00C0C0;
实:VOL,VOLSTICK;
换手:=VOL/CAPITAL*100;
贰换:SUM(V/CAPITAL*100,20),NODRAW,COLORMAGENTA;
动态市盈:=C/FINANCE(33),COLOR16CDEC,LINETHICK0 ;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK2;
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK2;
买卖盘:=-(主动买盘/主动卖盘),NODRAW,COLORYELLOW;
日净入(WS):(主动买盘+主动卖盘)/10000,NODRAW,COLORMAGENTA;
STICKLINE(主动买盘>0,0,主动买盘,1,0),COLORRED;
STICKLINE(主动卖盘<0,VOL,主动买盘,1,0),COLOR00FF00;
STICKLINE(换手>0 ,0, 主动买盘,0,0),COLORYELLOW;
STICKLINE(换手>0,VOL, 主动买盘, 0,0) ,COLORRED;
AHC2:=(HIGH - LOW);
AHC3:=ABS((OPEN - CLOSE));
AHC4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
AHC5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
AHC6:=((AHC3 / AHC2) * VOL);
AHC7:=((AHC4 / AHC2) * VOL);
AHC8:=((AHC5 / AHC2) * VOL);
AHCA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
AHCB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
AHCC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
AB601:=HHV(V,5);
AB602:=O>C;
AB702:=C>O;
AB703:=C=O;
AB704:=((SUM(V,5)/AB601));
AB705:=IF(AB704>0.3,1,0);
AB706:=IF(AB602 AND AB705,V,0);
AB707:=IF(AB702 AND AB705,V,0);
钱出A:=SUM(AB706,5),COLORGREEN,LINETHICK2;
钱入A:=SUM(AB707,5),COLORRED,LINETHICK2;
钱出:=SUM(AB706,20),COLORGREEN,LINETHICK2;
钱入:=SUM(AB707,20),COLORRED,LINETHICK2;
伍净入(SW):(钱入A-钱出A)/100000,COLORYELLOW,NODRAW;
贰净入:(钱入-钱出)/100000,COLORRED,NODRAW;
P5:MA(实,5),COLORMAGENTA,LINETHICK2;
P35:MA(实,35),COLORBLUE,LINETHICK2;
P135:MA(实,135),COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(P5,P135),(V *1.05),'★'),COLORYELLOW;
0,COLORBROWN;

通达信买盘卖盘控盘指标公式

 

相关文章