在线检测未来函数

通达信慢牛趋向指标公式

来源:Internet,编辑:股旁网,2015-01-23

{使用说明:主要用做波段的,红色区域进场或持股,绿色区域卖出或持币。}

IR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),3);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),3);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),3);
PDI:DMP*100/IR;
MDI:DMM*100/IR;
ADX:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,2);
ADXR:EXPMEMA(ADX,2);
DRAWBAND(PDI,RGB(240,0,0),MDI,RGB(0,120,0));
DRAWBAND(ADX,RGB(220,0,130),ADXR,RGB(240,240,0));
关注线:50,COLORF0F000,POINTDOT;
IF(ADX>ADXR,100,DRAWNULL),COLORF580F5,LINETHICK5;
IF(PDI>MDI,0,DRAWNULL),COLORF580F5,LINETHICK5;

通达信慢牛趋向指标公式

 

相关文章