在线检测未来函数

通达信换手柱子看趋势指标公式

来源:Internet,编辑:股旁网,2015-06-10

成交:=VOL,COLORFFFF00,LINETHICK0;
BB:=CAPITAL;
换手:成交*100/BB,LINETHICK0;
今日换手:换手,LINETHICK0;
HS:SUM(VOL,0)/CAPITAL,LINETHICK0;
换手次数:FLOOR(HS),LINETHICK0;
BBB:=IF(换手次数>0,换手次数,0);
BBB2:=IF(BBB-REF(BBB,1)>0,BBB,0);
距上次完全换手:=BARSLAST(BBB2),LINETHICK0,COLORGREEN;
平均换手天:=FLOOR((BARSCOUNT(CLOSE)-距上次完全换手)/换手次数),COLORCYAN,LINETHICK0;
A2:=成交/CAPITAL*100;
A3:=A2>3 AND A2<=5;
A4:=A2>5 AND A2<=7;
A5:=A2>7 AND A2<=10;
A6:=A2>10;
{STICKLINE(A2<3 AND C>O,0,A2,6,0),COLOR555500;
STICKLINE(A2<3 AND C>O,0,A2,5,0),COLOR777700;
STICKLINE(A2<3 AND C>O,0,A2,4,0),COLOR999900;
STICKLINE(A2<3 AND C>O,0,A2,3,0),COLORBBBB00;
STICKLINE(A2<3 AND C>O,0,A2,2,0),COLORDDDD00;
STICKLINE(A2<3 AND C>O,0,A2,1,0),COLORFFFF00;
}STICKLINE(A2<3 AND C>O,0,A2,3,0),COLORFFFF00;
{STICKLINE(A2<3 AND C<O,0,A2,6,0),COLOR005500;
STICKLINE(A2<3 AND C<O,0,A2,5,0),COLOR007700;
STICKLINE(A2<3 AND C<O,0,A2,4,0),COLOR009900;
STICKLINE(A2<3 AND C<O,0,A2,3,0),COLOR00BB00;
STICKLINE(A2<3 AND C<O,0,A2,2,0),COLOR00DD00;
STICKLINE(A2<3 AND C<O,0,A2,1,0),COLOR00FF00;
}STICKLINE(A2<3 AND C<O,0,A2,3,0),COLOR00FF00;
{STICKLINE(A3,0,A2,6,0),COLOR553300;
STICKLINE(A3,0,A2,5,0),COLOR774400;
STICKLINE(A3,0,A2,4,0),COLOR995500;
STICKLINE(A3,0,A2,3,0),COLORBB6600;
STICKLINE(A3,0,A2,2,0),COLORDD7700;
换手积极:STICKLINE(A3,0,A2,1,0),COLORFF8800;
}换手积极:STICKLINE(A3,0,A2,3,0),COLORFF8800;
{STICKLINE(A4,0,A2,6,0),COLOR555555;
STICKLINE(A4,0,A2,5,0),COLOR777777;
STICKLINE(A4,0,A2,4,0),COLOR999999;
STICKLINE(A4,0,A2,3,0),COLORBBBBBB;
STICKLINE(A4,0,A2,2,0),COLORDDDDDD;
换手活跃:STICKLINE(A4,0,A2,1,0),COLORYELLOW;
}换手活跃:STICKLINE(A4,0,A2,3,0),COLORYELLOW;
{STICKLINE(A5,0,A2,6,0),COLOR550000;
STICKLINE(A5,0,A2,5,0),COLOR770000;
STICKLINE(A5,0,A2,4,0),COLOR990000;
STICKLINE(A5,0,A2,3,0),COLORBB0000;
STICKLINE(A5,0,A2,2,0),COLORDD0000;
换手频繁:STICKLINE(A5,0,A2,1,0),COLORGREEN;
}换手频繁:STICKLINE(A5,0,A2,3,0),COLORGREEN;
{STICKLINE(A6,0,A2,6,0),COLOR000055;
STICKLINE(A6,0,A2,5,0),COLOR000077;
STICKLINE(A6,0,A2,4,0),COLOR000099;
STICKLINE(A6,0,A2,3,0),COLOR0000BB;
STICKLINE(A6,0,A2,2,0),COLOR0000DD;
巨幅换手:STICKLINE(A6,0,A2,1,0),COLOR0000FF;
}巨幅换手:STICKLINE(A6,0,A2,3,0),COLOR0000FF;
AA:=A2>1 AND A2<=3;
{STICKLINE(AA,0,A2,6,0),COLOR553300;
STICKLINE(AA,0,A2,5,0),COLOR773300;
STICKLINE(AA,0,A2,4,0),COLOR993300;
STICKLINE(AA,0,A2,3,0),COLORBB6600;
STICKLINE(AA,0,A2,2,0),COLORDD7700;
}STICKLINE(AA,0,A2,3,0),COLORDD7700;
BBB3:=CON2STR(REF(BBB,距上次完全换手),0);
DRAWTEXT(BBB2,A2,'次换手'),COLORFFFFFF;
DRAWTEXT(换手>REF(换手,1)*2,换手*0.8,'黑码'),COLORWHITE;
MA5:MA(换手,5),COLORRED,LINETHICK2;
MA10:MA(换手,10),COLORYELLOW,LINETHICK2;

通达信换手柱子看趋势指标公式

 

相关文章