在线检测未来函数

通达信加强版分时T+0+支撑线+强势线+机构出入货主图指标公式

来源:Internet,编辑:股旁网,2015-08-07

成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=(A2+A3);
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%%');
AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%%');
AAA3:=STRCAT(STRCAT('总买入',CON2STR((100*(A2-A3))/A6,0)),'%%');
DRAWTEXT_FIX(DD1=1,0,0.02,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.13,0,AAA2),COLOR00FF00;
DRAWTEXT_FIX(DD1=1,0,0.24,0,AAA3),COLOR00FFFF;D:='MK.明D#DAY';
Y:=D*(1+0.04);
Z:=D*(1-0.02);
K:=D*(1-0.04);
KJ2:REFDATE(Y,DATE),COLORCYAN,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=240,KJ2*(1-0.002),'1:压力线'),COLORYELLOW;
KJ4:REFDATE(D,DATE),COLORFF00FF,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=240,KJ4*(1+0.002),'2:强势线'),COLORYELLOW;
KJ5:REFDATE(Z,DATE),COLOR00FF00,LINETHICK3;
DRAWTEXT(CURRBARSCOUNT=240,KJ5*(1+0.002),'3:平衡线'),COLORYELLOW;
KJ6:REFDATE(K,DATE),COLORWHITE,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=240,KJ6*(1+0.002),'4:支撑线'),COLORYELLOW;
均:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;
DKX11:='DKX.DKX#DAY';
DKX22:='DKX.MADKX#DAY';
STICKLINE(DKX11>DKX22,DKX11,(DKX11+DKX11*0.002),2,0),COLORRED;
STICKLINE(DKX11<DKX22,DKX11,(DKX11+DKX11*0.002),2,0),COLORGREEN;
KK1:=DKX11*(1+0.005);
KK2:=DKX11*(1-0.005);
KKM:=IF(DKX11>KJ2,KK2,KK1);
DRAWTEXT(CURRBARSCOUNT=240,KKM,'长线—5:红多,6:绿空'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,KJ2*(1-0.002),'1压力线—注 意 风 险'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,KJ4*(1+0.002),'2强势线—突破2和6买2/3'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,KJ5*(1+0.002),'3平衡线—突破3和6买1/3'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,KJ5*(1-0.002),'......突破3和5最佳买点'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,KJ6*(1+0.002),'4支撑线——跌破止损'),COLORYELLOW;
DRAWTEXT(ISLASTBAR, KKM,'长线:—5红多,6绿空'),COLORYELLOW;
{DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,'突破:①注意风险')COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.10,0,'突破:②和⑥买2/3')COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.14,0,'突破:③和⑥买1/3')COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,'突破:③和⑤最佳买点')COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.22,0,'跌破:④止损')COLORRED;};
MA30:=EMA(CLOSE,30);
强弱:EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★'),COLORRED;{抛};

通达信加强版分时T+0+支撑线+强势线+机构出入货主图指标公式

 

相关文章