在线检测未来函数

通达信动力趋势指标公式

来源:Internet,编辑:股旁网,2015-09-13

DRAWBAND(130,RGB(130,130,130),-130,RGB(30,30,30));
DL:=WINNER(C/1.1)*100;
DL1:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*100;
DL2:=SMA(DL1,3,1);
DL2A:=SMA(DL2,3,1);
DL2B:=3*DL2-2*DL2A;
DL3:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
DL4:=SMA(DL3,2,1);
DL4A:=SMA(DL4,2,1);
DL4B:=3*DL4-2*DL4A;
DL6:=DL4B-DL2B;
DL7:=SMA(DL,3,1);
DL7A:=SMA(DL7,3,1);
DL7B:=3*DL7-2*DL7A;
动力:IF(DL7B>20,DL7B,1),LINETHICK0,COLORYELLOW;
趋势:IF(DL6>20,DL6,1),LINETHICK0,COLOR0000FF;
IF(动力>1,动力,0),LINETHICK2,COLORYELLOW;
IF(动力>1,-动力,0),LINETHICK2,COLORYELLOW;
IF(动力=1 AND 动力<REF(动力,1),动力,DRAWNULL),LINETHICK2,COLORCYAN;
IF(动力=1 AND 动力<REF(动力,1),-动力,DRAWNULL),LINETHICK2,COLORCYAN;
IF(动力=1 AND 动力=REF(动力,1),0,DRAWNULL),LINETHICK2,COLORBLUE;
IF(趋势>1,趋势,0),LINETHICK2,COLOR0000FF;
IF(趋势>1,-趋势,0),LINETHICK2,COLOR0000FF;
IF(趋势=1 AND 趋势<REF(趋势,1),趋势,0),LINETHICK2,COLORGREEN;
IF(趋势=1 AND 趋势<REF(趋势,1),-趋势,0),LINETHICK2,COLORGREEN;
IF(趋势=1 AND 趋势=REF(趋势,1),0,DRAWNULL),LINETHICK2,COLORWHITE;
80,COLORGREEN,LINETHICK2,POINTDOT;
0,COLORWHITE,LINETHICK1,POINTDOT;
-80,COLORGREEN,LINETHICK2,POINTDOT;
DRAWTEXT_FIX(C>0,0,0,0,'趋势一出,短线可捉,上穿八十,强势追击'),COLORGREEN;
DRAWTEXT_FIX(C>0,0,0.05,0,' \N动力出现,大涨可见,红黄消失,清仓休息'),COLORGREEN;

通达信动力趋势指标公式

 

相关文章