在线检测未来函数

通达信MACD共震指标公式

来源:Internet,编辑:股旁网,2015-09-27

DIF周:=EMA(CLOSE,12*5)-EMA(CLOSE,26*5);
DEA周:=EMA(DIF周,9*5);
MACD周:=(DIF周-DEA周)*2;
DIF日:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA日:=EMA(DIF日,9);
MACD日:=(DIF日-DEA日)*2;
DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
MACD60:=(DIF60-DEA60)*2;
DIF30:=(EMA(CLOSE,12/4)-EMA(CLOSE,26/4));
DEA30:=(EMA(DIF30,9/4));
MACD30:=(DIF30-DEA30)*2;
STICKLINE(MACD周>=0,0,MACD周,3,1),COLORRED;
STICKLINE(MACD周<0,0,MACD周,3,1),COLORFFFF00;
STICKLINE(MACD日>=0,0,MACD日,1.8,0),COLORRED;
STICKLINE(MACD日<0,0,MACD日,1.8,0),COLORFFFF00;
STICKLINE(MACD60>=0,0,MACD60,1,0),COLORYELLOW;
STICKLINE(MACD60<0,0,MACD60,1,0),COLORFFFF00;
STICKLINE(MACD30>=0,0,MACD30,0.5,0),COLORFF00FF;
STICKLINE(MACD30<0,0,MACD30,0.5,0),COLORFFFF00;
MACD日0:REF(MACD日,BARSLAST(MACD日=HHV(MACD日,0))),COLORWHITE,LINETHICK1;
MACD周0:REF(MACD周,BARSLAST(MACD周=HHV(MACD周,0))),COLORGREEN,LINETHICK1;

通达信MACD共震指标公式

 

相关文章