在线检测未来函数

通达信趋势神器主图指标公式

来源:Internet,编辑:股旁网,2015-10-12

AAASH:=(3*C+H+L+O)/6;
VARSH1:(8*AAASH+7*REF(AAASH,1)+6*REF(AAASH,2)+5*REF(AAASH,3)+4*REF(AAASH,4)+3*REF(AAASH,5)+2*REF(AAASH,6)+REF(AAASH,8))/36,LINETHICK2,COLORYELLOW;
VARSH2:=(HHV(VARSH1,2)+HHV(VARSH1,4)+HHV(VARSH1,8))/3;
VARSH3:=(LLV(VARSH1,2)+LLV(VARSH1,4)+LLV(VARSH1,8))/3;
VARSH4:=(HHV(VARSH2,2)+HHV(VARSH2,4)+HHV(VARSH2,8))/3,COLORWHITE;
VARSH5:=(LLV(VARSH3,2)+LLV(VARSH3,4)+LLV(VARSH3,8))/3;
VARSH6:=(LLV(VARSH1,2)+LLV(VARSH1,4)+LLV(VARSH1,8))/3,COLORWHITE;
{DRAWBAND(VARSH1,RGB(155,50,50),VARSH6,RGB(250,250,0));}
{DRAWBAND(VARSH4,RGB(100,180,50),VARSH1,RGB(100,180,50));}
QSXX:IF((VARSH1 <= REF(VARSH1,1)),VARSH1,DRAWNULL),COLORGREEN,LINETHICK2;
QSXS:IF((VARSH1 >= REF(VARSH1,1)),VARSH1,DRAWNULL),COLORRED,LINETHICK2;
DRAWKLINE(H,O,L,C);
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13),COLORYELLOW;
上轨:=1.06*AHC2,LINETHICK2,COLORWHITE;
顶:1.13*AHC2,LINETHICK2,COLORBLUE;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆1:=CROSS(C,上轨) AND ZT;
DRAWTEXT(启爆1,L*0.98,'启爆'),COLORYELLOW;
超牛:=CROSS(C,顶) AND ZT;
DRAWTEXT(超牛,L*0.98,'超牛'),COLORRED;

通达信趋势神器主图指标公式

 

相关文章