在线检测未来函数

通达信登峰趋势指标公式

来源:Internet,编辑:股旁网,2015-12-02

N:=5;
MB1:=EMA(EMA((C-REF(C,1)),6),6)*100/EMA(EMA(ABS((C-REF(C,1))),6),6),COLORYELLOW;
MB2:EMA(MB1,2),COLORBLUE;
MB3:EMA(MB2,2),COLORBLUE;
MB4:EMA(MB3,2),COLORBLUE;
MB5:EMA(MB4,2),COLORBLUE;
MB6:EMA(MB5,2),COLORBLUE;
MB7:EMA(MB6,2),COLORBLUE;
MB8:EMA(MB7,2),COLORBLUE;
MB9:EMA(MB8,2),COLORBLUE;
MB10:EMA(MB9,2),COLORBLUE;
MB11:EMA(MB10,2),COLORBLUE;
MB12:EMA(MB11,2),COLORBLUE;
MB13:EMA(MB12,2),COLORBLUE;
MB14:EMA(MB13,2),COLORBLUE;
VAR2:MB1,LINETHICK2;
VAR3:DRAWLINE(VAR2>=HHV(VAR2,N)=1,VAR2,VAR2<=LLV(VAR2,N)=1,VAR2,1),COLORMAGENTA;
STICKLINE(VAR2=VAR3 AND VAR2<MB4,VAR2,VAR2+6,1,0),COLORMAGENTA;
STICKLINE(REF(VAR2,1)=REF(VAR3,1) AND VAR2>REF(VAR2,1),VAR2,VAR2+6,1,0),COLORRED;
VAR3A:DRAWLINE(VAR2<=LLV(VAR2,N)=1,VAR2,VAR2>=HHV(VAR2,N)=1,VAR2,1),COLORYELLOW;
STICKLINE(VAR2=VAR3A AND VAR2>MB4,VAR2,VAR2-6,1,0)COLORGREEN;
STICKLINE(REF(VAR2,1)=REF(VAR3A,1) AND VAR2<REF(VAR2,1),VAR2,VAR2+6,1,0),COLORYELLOW;

通达信登峰趋势指标公式

 

相关文章