在线检测未来函数

大智慧VOL猎狼量指标公式

来源:Internet,编辑:股旁网,2015-12-03

input:M1(5),M2(10),N(20);
DRAWTEXTREL(600,10,' ★【猎狼老头】:日净流入量 单位:手'),color00FF00;
V1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,COLORCD52FF,STICK3D,PRECIS0;
主买:IF(CLOSE>OPEN,V1*(HIGH-LOW),IF(CLOSE<OPEN,V1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLOR0000FF,STICK3D,PRECIS0;
主卖:IF(CLOSE>OPEN,0-V1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-V1*(HIGH-LOW),0-VOL/2)),COLOR00E522,STICK3D,PRECIS0;
主卖盘:=IF(CLOSE>OPEN,V1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,V1*(HIGH-LOW),VOL/2));
买卖差:=(主买+主卖);
买卖差比:买卖差/CAPITAL*100;
猎狼线:=0;
FILLRGN(买卖差,猎狼线,买卖差>=猎狼线,RGB(155,0,0),买卖差<猎狼线,RGB(0,150,0)),PRECIS0;
今日净买:(主买+主卖)/10000,COLORMAGENTA,LINETHICK0,PRECIS2;
买卖比:主买/主卖盘;
图长度像素:=380*0.4;
主动买盘长度:=主买/1000000*图长度像素+180;
主动卖盘长度:=主卖盘/1000000*图长度像素+180;
DRAWTEXTABS(10,5,'主买盘: '+NUMTOSTRN(主买,1)+'手★┣→'),COLOR0000FF,LINETHICK2,PRECIS0;
DRAWTEXTABS(10,25,'主卖盘:'+NUMTOSTRN(主卖,1)+'手★┣→'),COLOR00FFFF,LINETHICK2,PRECIS0;
DRAWRECTABS(180,5,主动买盘长度,20 ,RGB(200,60,0)),COLOR6699FF;
DRAWRECTABS(180,25,主动卖盘长度,40 ,RGB(0,255,0) ),COLORFFFFFF;
DRAWTEXTREL(850,920,'成交量雷达'),COLORFF00FF,LINETHICK4;
N日净量:SUM(今日净买,N),LINETHICK0,PRECIS1;
N日内创新高:=N日净量=HHV(N日净量,N);
DRAWTEXT(N日内创新高,V,'↑'),COLORFF0000;
MA1:MA(VOL,M1),LINETHICK2,COLORFFFFFF;
MA2:MA(VOL,M2),LINETHICK2,COLORYELLOW;
天量:=VOL=HHV(VOL,0);
DRAWTEXT(天量,天量,'天量'),COLOR00FFFF;
量34:MA(VOL,34),COLOR00FF00,LINETHICK2;
L13:=LLV(MA(VOL,5),13);
PARTLINE(M1,(M2< M1)),COLORFF00FF,LINETHICK2;
PARTLINE(量34,M2>量34),COLOR0000FF,LINETHICK2;
DRAWTEXT(REF(COUNT(VOL>L13,8)=8,1) and VOL<L13,VOL,'↓缩'),coloryellow;
DRAWTEXT(REF(COUNT(VOL<量34,8)=8,1) and VOL>量34,VOL,'↑增'),coloryellow;

大智慧VOL猎狼量指标公式

 

相关文章