在线检测未来函数

通达信双色趋势主图指标公式

来源:Internet,编辑:股旁网,2015-12-19

MA3:MA(C,5),COLOR000999;
MA10:MA(C,10),COLOR008364;
MA21:MA(C,21),COLORGRAY;
VAR1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR2:=MA(VAR1,5);
VAR3:=MA(VAR1,10);
多方: DRAWTEXT(FILTER(MA(VAR1,10)<VAR2,1),VAR3,'^'),COLORRED;
空方: DRAWTEXT(FILTER(MA(VAR1,10)>=VAR1,1),VAR3,','),COLORGREEN ;
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
STICKLINE(X2>=X3,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3,1),COLORE66878;
STICKLINE(X2<X3,LOW,HIGH,0.1,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,3,1),COLORFF937F;
VAR11:=REF(CLOSE,1);
VAR21:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
VAR31:=(CLOSE-VAR1)*VAR2;
VAR4:=SUM(VAR3,0);
VAR5:=SMA(VAR4,5,1);
VAR6:=SMA(VAR4,8,1);
OSC:=VAR5-VAR6;
OSCMA:=MA(OSC,4);
VD:=SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;
VE:=SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34;
VARW:=(C/REF(C,1)-1)*100<=4;
KOH:=L>REF(H,1);
KOL:=H<REF(L,1);
HIF:=L>REF(H,BARSLAST(KOH)+1);
NHIF:=L<=REF(H,BARSLAST(KOH)+1);
LIF:=H<REF(L,BARSLAST(KOL)+1);
NLIF:=H>=REF(L,BARSLAST(KOL)+1);
DRAWICON(HIF AND BARSLAST(KOH)<BARSLAST(NHIF) AND BARSLAST(HIF)<BARSLAST(NHIF),REF(H,BARSLAST(KOH)+1),38);
DRAWICON(LIF AND BARSLAST(KOL)<BARSLAST(NLIF) AND BARSLAST(LIF)<BARSLAST(NLIF),REF(L,BARSLAST(KOL)+1),39);

通达信双色趋势主图指标公式

 

相关文章