在线检测未来函数

通达信红兰带趋势指标公式

来源:Internet,编辑:股旁网,2016-03-02

分水岭: DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL),COLOR00FFFF,LINETHICK2;
CCC:C,COLORFFFFFF;
UPPER : MA(CLOSE,14)*1.06,POINTDOT,COLORFF99FF,LINETHICK2;
LOWER : MA(CLOSE,14)*0.94,POINTDOT,COLORFF00FF,LINETHICK2;
MID:(UPPER+LOWER)/2,NODRAW,COLOR00FFFF,LINETHICK1;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(VAR1,1)+EMA(VAR1,2)+EMA(VAR1,3)+EMA(VAR1,4))/4,COLORCYAN,LINETHICK1;
W1:=(EMA(VAR1,1)+EMA(VAR1,2)+EMA(VAR1,3)+EMA(VAR1,4))/4;
A2: EMA(A1,2),COLORCYAN,LINETHICK1;
W2:=EMA(A1,2);
A3: EMA(A2,2),COLORCYAN,LINETHICK1;
W3:=EMA(A2,2);
A4: EMA(A3,2),COLORCYAN,LINETHICK1;
W4:=EMA(A3,2);
A5: EMA(A4,2),COLORCYAN,LINETHICK1;
W5:=EMA(A4,2);
A6: EMA(A5,2),COLORCYAN,LINETHICK1;
W6:= EMA(A5,2);
A7: EMA(A6,2),COLORCYAN,LINETHICK1;
W7:= EMA(A6,2);
IF(W1>REF(W1,1),A1,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W2,1),A2,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W3,1),A3,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W4,1),A4,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W5,1),A5,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W6,1),A6,DRAWNULL),COLORRED,LINETHICK1;
IF(W2>REF(W7,1),A7,DRAWNULL),COLORRED,LINETHICK1;
DRAWICON(CROSS(CCC,LOWER ) AND CROSS(CCC,A3 ),LOWER,23);
DRAWICON(CROSS(UPPER,CCC),UPPER,15);
DRAWTEXT(CROSS(CCC,UPPER),UPPER,'A'),COLORYELLOW;

通达信红兰带趋势指标公式

 

相关文章