在线检测未来函数

通达信自用A主图指标公式

来源:Internet,编辑:股旁网,2016-04-08

{MA线}
M5:MA(C,5),COLORWHITE,LINETHICK1;
M10:MA(C,10),COLORYELLOW,LINETHICK1;
M20:MA(C,20),COLORCYAN,LINETHICK1;
M60:MA(C,60),COLORGREEN,LINETHICK1;
M120:MA(C,120),COLORRED,LINETHICK1;
{支撑阻力}
VV1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
VV2:=(1-7/100)*(DMA(CLOSE,VV1));
VV3:=(1+7/100)*(DMA(CLOSE,VV1));
VV5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(VV2,DATE),DOTLINE,LINETHICK1,COLORCC66FF;
阻力:REFDATE(VV3,DATE),DOTLINE,LINETHICK1,COLORGREEN;
{市场成本}
MCST:DMA(AMOUNT/(100*VOL),VOL/CAPITAL),NODRAW;
AA1:=MA(C,5);
BB1:=MA(C,15);
AF:=CROSS(AA1,BB1);
STICKLINE(AF,LLV(L,4),LLV(L,4),50,1),COLORRED,LINETHICK3;
DRAWTEXT(AF,LLV(L,4),'----------止损线----------'),COLORYELLOW;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.6,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
跌停:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(涨跌停>9.8,O,C,2,0),COLORYELLOW;
STICKLINE(涨跌停<-9.8,O,C,2,0),COLORGREEN;
STICKLINE(涨跌停>6 AND 涨跌停<9.8,O,C,2,0),COLORRED;
{青云}
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
DRAWTEXT(FILTER(MR,10),LOW*0.985,'●青云'),COLORFF00FF;
{加仓}
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'↖加仓'),COLORFFFF00;
{满仓}
MA2:=EMA(C,2);
MA5:=EMA(C,5);
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
YCX:=MA5>=REF(MA5,1);
H5:=MAX(MAX(MA5,EMA13),EMA30);
L5:=MIN(MIN(MA5,EMA13),EMA30);
一阳穿三线:= H5<C AND O<L5 AND YCX AND MA2>REF(MA2,1);
DRAWTEXT(一阳穿三线,LOW*0.98,'←满'),COLOR00FFFF;
{主力建仓}
指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20;
DRAWTEXT(指标王,L*0.99,'↖主力建仓'),COLOR00FFFF;
{建仓}
买线:=MA(CLOSE,9);
卖线:=MA(CLOSE,20);
BU:=CROSS(买线,卖线);
DRAWTEXT(BU,L-0.3,'↖建')COLORYELLOW;
{缩量涨带量跌}
HV:=HHV(V,5)=V OR V/REF(V,1)>=5;
FT:=BARSLAST(HV);
量能平台1:=IF(HV,C,REF(C,FT));
DRAWTEXT(量能平台1>REF(量能平台1,1)AND C<REF(C,1),H,'←-带量跌'),COLORGREEN;
DRAWTEXT(量能平台1<REF(量能平台1,1) AND C>REF(C,1),H,'↙缩量涨'),COLORYELLOW;
DRAWTEXT(量能平台1>REF(量能平台1,1) AND C>REF(C,1) AND C>MA(C,13) AND C=HHV(C,20) AND C/REF(C,1)>1.05,H,'←-突破量'),COLOR00FFFF;
{启爆点}
AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上轨:=1.06*AHC22;
下轨:=AHC22*0.94;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
DRAWTEXT(启爆,L,'↖启爆'),COLORCYAN;
{强势狙击}
AAZ5:=MA(C,5),COLOR0099CC;
BB05:=ATAN((AAZ5/REF(AAZ5,1)-1)*100)*180/3.1416;
AA10:=MA(C,10);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AAZ30:=MA(C,30);
BB30:=ATAN((AAZ30/REF(AAZ30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
DRAWICON(强势狙击 ,LOW*0.991,41);
DRAWTEXT(强势狙击 ,LOW*0.995,'←强势狙击'),COLOR0000FF;
{龙出海}
Y:=(MA(C,5)-MA(C,30))/MA(C,5)*100;
YY1:=C>MA(C,5) AND OPEN<MA(C,5);{龙出海}
YY3:=C>MA(C,10) AND OPEN<MA(C,10);
YY5:=C>MA(C,30) AND OPEN<MA(C,30);
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.2,'←龙出海'),COLORYELLOW;
BS:EMA(C,5)NODRAW;
DRAWTEXT(CROSS(CLOSE,BS),L*0.99,'★'),COLOR00FFFF;

通达信自用A主图指标公式

 

相关文章