在线检测未来函数

通达信山峰指标公式

来源:Internet,编辑:股旁网,2016-04-18

Var1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
山峰:SMA(Var1,5,1)-8,LINETHICK2,COLORCYAN;
STICKLINE(山峰,0,山峰,1,0),COLORC8FF00;
Var2:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
Var3:=SMA(Var2,5,1)-16;
STICKLINE(Var3>山峰,0,-5,4,2),COLORYELLOW;
STICKLINE(Var3<山峰,0,-5,4,2),COLOR9800FF;
山谷: STICKLINE(FILTER(CROSS(Var3,山峰),5)=1 AND 山峰<15,0,20,13,2),COLORgreen;
DRAWTEXT(FILTER(CROSS(Var3,山峰),5)=1 AND 山峰<15,-12,'山谷'),COLORgreen;
山头: STICKLINE(CROSS(山峰,Var3) AND Var3>=55 AND Var3<70,0,75,13,0),COLORYELLOW;
DRAWTEXT(CROSS(山峰,Var3) AND Var3>=55 AND Var3<70,-12,'跑吧'),COLORYELLOW;
山顶:STICKLINE(FILTER(CROSS(山峰,80),20)=1,0,85,25,0),COLORred;
DRAWTEXT(FILTER(CROSS(山峰,80),20)=1,-12,'山顶'),COLORred;
大本营: -20,CIRCLEDOT,COLOR3098FF;
Var4:=SMA(Vol,5,1);
Var5:=(Var4-llv(Var4,10))/(hhv(Var4,10)-llv(Var4,10))*100;
Var6:=SMA(Var5,3,1);
Var7:=100-Var6;
Var8:=REF(Var7,1)>REF(Var7,2) AND Var7<34;
Var9:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Var10:=FILTER(Var8,3);
群山:SMA(Var9,3,1),COLORBLUE,LINESTICK;
下山:STICKLINE(Var10 AND 群山>60,0,75,13,0),colormagenta;
DRAWTEXT(Var10 AND 群山>60,-12,'下山'),colormagenta;

通达信山峰指标公式

 

相关文章