在线检测未来函数

通达信横盘突破抓涨停分时主图指标公式

来源:Internet,编辑:股旁网,2016-04-29

均线:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),
1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;
均线H:(均线*1.007 ),COLORFF6600;
均线L:(均线/1.005 ),COLOR00FF00;
均线横盘:=C<均线H AND C>均线L;
STICKLINE(均线横盘,均线L,均线,3,0),COLORYELLOW;
放量:=SUM(VOL,6)>REF(MA(VOL,30),1)*10;
横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;
横涨:=横盘 AND 放量 AND (C>均线H);
横跌:=横盘 AND 放量 AND CROSS(均线L,C) ;
突破:=FILTER(横涨,100);
下破:=FILTER(横跌,50);
DRAWTEXT(突破,均线H,'★突破'),COLORFF00FF;
MA30:=EMA(CLOSE,30);
强弱界定:EMA(CLOSE,900);
STICKLINE((MA30>强弱界定),MA30,强弱界定,1,0),COLOR0000FF;
STICKLINE((MA30<强弱界定),MA30,强弱界定,1,0),COLOR00FF00;
DRAWICON(CROSS(MA30,强弱界定),H,24);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
CC:CLOSE,COLORWHITE,LINETHICK2;
STICKLINE(突破>0,支撑,阻力,2,0),COLORRED;
JX:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),
1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;
A1:=(VOL/CLOSE)/3;
A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
机构买盘:=(A2),LINETHICK2;
机构卖盘:=(A3),LINETHICK2;
散户买盘:=(A4);
散户卖盘:=(A5);
DRAWTEXT_FIX(1,0.000,1-0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.250,1-0.05,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLOR00FF00;
DRAWTEXT_FIX(1,0.500,1-0.05,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.745,1-0.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;
大单买量:=SUM(IF(C>REF(C,1) AND V>4000,V,0),0),NODRAW;
大单卖量:=SUM(IF(C<REF(C,1) AND V>4000,V,0),0),NODRAW;
买单总量:=SUM(IF(C>REF(C,1),V,0),0),NODRAW;
卖单总量:=SUM(IF(C<REF(C,1),V,0),0),NODRAW;
小单买量:=买单总量-大单买量,NODRAW;
小单卖量:=卖单总量-大单卖量,NODRAW;
DRAWRECTREL(0,1000,147,999.4,IF(120,RGB(10,0,0),1));
大宗进:=大单买量,NODRAW;
大宗出:=大单卖量,NODRAW;
非大宗进:=小单买量,NODRAW;
非大宗出:=小单卖量,NODRAW;
主力净流入:=大单买量-大单卖量,COLORRED,NODRAW;
散户净流入:=小单买量-小单卖量,COLORRED,NODRAW;
净流入:=买单总量-卖单总量,COLORRED,NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(0,255,0)));
DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(0,255,0),RGB(255,0,0)));
DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(150,0,0),RGB(0,150,150)));
DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(0,150,150),RGB(150,0,0)));
DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(255,255,0),RGB(23,125,255)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;
DRAWTEXT_FIX(1,0.145,0.99,0,STRCAT(STRCAT('净流入 ',CON2STR(净流入,0)),'万')),COLORYELLOW;

通达信横盘突破抓涨停分时主图指标公式

 

相关文章